CVE-2026-8139 Concrete CMS 9.5.0 and below is vulnerable to Stored XSS via external-link page cvName
Attackers can inject malicious scripts into external-link page names, leading to stored XSS attacks against other users.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-8139?
CVE-2026-8139 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Concrete CMS 9.5.0 and below is vulnerable to Stored XSS via external-link page cvName because updateCollectionAliasExternal bypasses being sanitized. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 2.0 with vector CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N. Thanks Yonatan Drori (Tenzai) for reporting.
Weakness: CWE-79
Which versions are affected by CVE-2026-8139?
2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | All versions | 9.5.1 |
concrete5/concrete5 Packagist | All versions | 9.5.1 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2026-8139?
Upgrade concrete5/concrete5 to 9.5.1 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-8139 being exploited?
There is no known exploitation of CVE-2026-8139 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-pcrh-gj77-j4mw.