# CVE-2026-8147: Authorization Bypass in mlflow/mlflow

> Authenticated users can bypass authorization checks to read, modify, or delete traces in unauthorized MLflow experiments when authentication is enabled.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2026
- **Updated:** 2 Jul 2026
- **Also known as:** BIT-mlflow-2026-8147, CLSA-2026-1788442606, GHSA-2cm6-r77w-6g96, PYSEC-2026-3686

## What is CVE-2026-8147?

CVE-2026-8147 is a high-severity missing authorization vulnerability in Lfprojects Mlflow, published on 2 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In MLflow versions prior to 3.14.0, when running with authentication enabled, the trace API endpoints lack proper authorization validators. This allows any authenticated user to bypass experiment-level authorization controls on all trace operations, including reading, deleting, and modifying traces on experiments they do not have permission to access. The issue arises from the `_before_request` handler, which does not register authorization validators for trace endpoints, resulting in requests proceeding without validation. This vulnerability can expose sensitive data, destroy audit logs, and allow unauthorized modifications.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-8147?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.14.0 |
| `mlflow` | PyPI | From 2.14.0rc0 | 3.13.0rc0 |
| `mlflow` | PyPI | From 2.14.0rc0 | 3.13.0rc0 |
| `mlflow` | PyPI | From 2.14.0rc0 | 3.13.0rc0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2026-8147?

Upgrade mlflow to a fixed version for your release line: 3.14.0 or 3.13.0rc0.

## Is CVE-2026-8147 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8147 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8147 and fix it if it is affected.

What it is: CVE-2026-8147 is a high-severity missing authorization vulnerability in Lfprojects Mlflow, published on 2 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8147 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.14.0
- mlflow (PyPI): affected from 2.14.0rc0; fixed in 3.13.0rc0
- mlflow (PyPI): affected from 2.14.0rc0; fixed in 3.13.0rc0
- mlflow (PyPI): affected from 2.14.0rc0; fixed in 3.13.0rc0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8147/ (Markdown: https://insights.sbomify.com/CVE-2026-8147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8147
- OSV: https://osv.dev/vulnerability/CVE-2026-8147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8147/
Summaries are generated and may contain mistakes; the official description above is the record.
