# CVE-2026-8149: GCM chunking can lead to bad tag exception on decryption

> A flaw in Bouncy Castle GCM chunking causes decryption exceptions, potentially leading to denial of service for applications using affected versions.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/S:N/RE:M/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 21 Jul 2026
- **Also known as:** CLEANSTART-2026-JO17621, GHSA-mx76-r943-rf8g, MINI-3945-g8c4-6wj7

## What is CVE-2026-8149?

CVE-2026-8149 is a medium-severity denial of service vulnerability in Legion of the Bouncy Castle Inc. BC-FJA, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability in Legion of the Bouncy Castle Inc. BC-LTS bcprov-lts8on on X86_64, AVX, AVX-512f, Linux, Legion of the Bouncy Castle Inc. BC-FJA bc-fips on Linux, X86_64, AVX, AVX-512f.

 This vulnerability is associated with program files gcm128w, gcm512w, gcm128w.C, gcm512w.C.

This issue affects BC-LTS: from 2.73.0 before 2.73.11; BC-FJA: from 2.1.0 before 2.1.3.

Weakness: CWE-1068 (Inconsistency Between Implementation and Documented Design)

## Which versions are affected by CVE-2026-8149?

2 open source packages ship an affected version, including org.bouncycastle:bcprov-lts8on.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.bouncycastle:bcprov-lts8on` | Maven | From 2.73.0 | 2.73.11 |
| `org.bouncycastle:bcprov-lts8on` | Maven | From 2.73.0 | 2.73.11 |

## How do I fix CVE-2026-8149?

Upgrade org.bouncycastle:bcprov-lts8on to 2.73.11 or later.

## Is CVE-2026-8149 being exploited?

There is no known exploitation of CVE-2026-8149 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8149 and fix it if it is affected.

What it is: CVE-2026-8149 is a medium-severity denial of service vulnerability in Legion of the Bouncy Castle Inc. BC-FJA, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-8149 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.bouncycastle:bcprov-lts8on (Maven): affected from 2.73.0; fixed in 2.73.11
- org.bouncycastle:bcprov-lts8on (Maven): affected from 2.73.0; fixed in 2.73.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8149/ (Markdown: https://insights.sbomify.com/CVE-2026-8149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8149
- OSV: https://osv.dev/vulnerability/CVE-2026-8149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8149/
Summaries are generated and may contain mistakes; the official description above is the record.
