CVE-2026-81637 Replayable OAuth2 CSRF state retained after a failed callback in AshAuthentication
Attackers can replay OAuth2 state values after failed callbacks to sign victims into attacker-controlled accounts due to insufficient session expiration.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-81637?
CVE-2026-81637 is a low-severity vulnerability in team-alembic ash_authentication, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Insufficient Session Expiration vulnerability in team-alembic AshAuthentication allows an attacker who obtains a victim's OAuth2 state value to replay the callback and sign that victim into an attacker-controlled account.
AshAuthentication.Strategy.OAuth2.Plug.callback/2 clears the stored session_params through a rebinding step inside its with chain, conn <- delete_session(conn, session_key). Elixir evaluates the else block in the scope enclosing the with, so every failure path (the provider returning ?error=access_denied, an invalid code, a token-exchange error, or a registration or sign-in failure) reaches store_authentication_result/2 holding the original connection and the session entry is never removed. The value the module's own comment describes as protection against a CSRF-related attack is therefore consumed only when authentication succeeds, and survives a cancelled or failed attempt until the next request phase or session expiry.
This issue affects ash_authentication: from 0.6.0 before 4.15.0 and from 5.0.0-rc.0 before 5.0.0-rc.14.
Weakness: CWE-613
Which versions are affected by CVE-2026-81637?
1 open source package ship an affected version, including ash_authentication.
| Package | Affected | Fixed in |
|---|---|---|
ash_authentication Hex | From 0.6.0 | 4.15.0, 5.0.0-rc.14 |
How do I fix CVE-2026-81637?
Upgrade ash_authentication to a fixed version for your release line: 4.15.0 or 5.0.0-rc.14.
Is CVE-2026-81637 being exploited?
There is no known exploitation of CVE-2026-81637 in the wild and no public exploit code.
Sources
Also known as EEF-CVE-2026-81637, GHSA-3vcj-gxx8-3p44.