# CVE-2026-81643: Missing authorization in ash graphql

> Attackers can view unauthorized GraphQL subscription data because authorization checks are skipped for all but the first notification in a batch.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** EEF-CVE-2026-81643, GHSA-j684-hch4-q888

## What is CVE-2026-81643?

CVE-2026-81643 is a low-severity missing authorization vulnerability in ash-project ash_graphql, published on 30 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in ash-project ash_graphql delivers GraphQL subscription payloads for records a subscriber is not authorized to see.

In AshGraphql.Subscription.Batcher, do_send/5 resolves the first notification of a batch and filters it with should_send?/1, which drops results whose errors are coded forbidden or not_found or carry no code, precisely so that unauthorized results are not disclosed. The remaining notifications in the batch are read from the process dictionary, re-run through the pipeline, and appended to the outgoing results without that filter. They reach pubsub.publish_subscription/2, and the not is_nil(record) guard drops only nil records, not error-carrying results. Any two qualifying notifications arriving within the default one-second batch interval suffice, and batching is the default path. The fix applies should_send?/1 to the whole batch.

This issue affects ash_graphql: from 1.4.0 before 1.11.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-81643?

1 open source package ship an affected version, including ash_graphql.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_graphql` | Hex | From 1.4.0 | 1.11.0 |

## How do I fix CVE-2026-81643?

Upgrade ash_graphql to 1.11.0 or later.

## Is CVE-2026-81643 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-81643 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81643 and fix it if it is affected.

What it is: CVE-2026-81643 is a low-severity missing authorization vulnerability in ash-project ash_graphql, published on 30 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-81643 exists.

Affected packages and fixed versions:
- ash_graphql (Hex): affected from 1.4.0; fixed in 1.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81643/ (Markdown: https://insights.sbomify.com/CVE-2026-81643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81643
- OSV: https://osv.dev/vulnerability/CVE-2026-81643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81643/
Summaries are generated and may contain mistakes; the official description above is the record.
