CVE-2026-81684 openssl_encrypt before 1.4.9 Information Disclosure via Command Line

Medium 6.9 Published Updated

Local attackers can read steganography passwords from process command lines, exposing sensitive data to any user on the system.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-81684?

CVE-2026-81684 is a medium-severity vulnerability in Jahlives Openssl Encrypt, published on 27 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

In openssl_encrypt (pip package openssl-encrypt) versions <= 1.4.8, the desktop GUI passes the steganography password to the CLI child process on the command line via the --stego-password argument (on both encrypt and decrypt paths) instead of via an environment variable as done for the main password. Any local user can read the steganography password from /proc/<pid>/cmdline for the lifetime of the subprocess. Fixed in 1.4.9.

Weakness: CWE-214

Which versions are affected by CVE-2026-81684?

1 open source package ship an affected version, including openssl-encrypt. It affects 1 product.

PackageAffectedFixed in
openssl-encrypt PyPIAll versions1.4.9

Products include Jahlives Openssl Encrypt.

How do I fix CVE-2026-81684?

Upgrade openssl-encrypt to 1.4.9 or later.

Is CVE-2026-81684 being exploited?

There is no known exploitation of CVE-2026-81684 in the wild and no public exploit code.

All Jahlives Openssl Encrypt vulnerabilities

Sources

Also known as GHSA-82vg-rggx-556v, GHSA-rx2c-m92f-qv6p, PYSEC-2026-3958.

Is CVE-2026-81684 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free