# CVE-2026-81696: openssl_encrypt before 1.4.9 Terminal Injection via info Command

> Attackers can forge verification information in terminal output by crafting malicious files with escape sequences, misleading users about file integrity.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2026
- **Updated:** 1 Oct 2026
- **Also known as:** GHSA-539p-fxf4-7fv8, GHSA-mww3-xh7q-jwwm, PYSEC-2026-3775

## What is CVE-2026-81696?

CVE-2026-81696 is a critical vulnerability in Jahlives Openssl Encrypt, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

openssl_encrypt versions before 1.4.9 fail to sanitize terminal control characters in file metadata printed by the info command. Attackers can craft malicious files containing escape sequences to repaint terminal output and forge verification information displayed to users.

Weakness: CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2026-81696?

1 open source package ship an affected version, including openssl-encrypt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-encrypt` | PyPI | All versions | 1.4.9 |

Products: Jahlives Openssl Encrypt.

## How do I fix CVE-2026-81696?

Upgrade openssl-encrypt to 1.4.9 or later.

## Is CVE-2026-81696 being exploited?

There is no known exploitation of CVE-2026-81696 in the wild and no public exploit code.

## Other vulnerabilities in Jahlives Openssl Encrypt

- [CVE-2026-81680](https://insights.sbomify.com/CVE-2026-81680/): openssl_encrypt before 1.4.9 Authentication Bypass via Recovery Slot Removal (critical 9.3)
- [CVE-2026-81681](https://insights.sbomify.com/CVE-2026-81681/): openssl_encrypt before 1.4.9 False Encryption via Cleartext Storage (critical 9.3)
- [CVE-2026-81685](https://insights.sbomify.com/CVE-2026-81685/): openssl_encrypt before 1.4.9 Text Injection via Recovery Slot Metadata (critical 9.3)
- [CVE-2026-81694](https://insights.sbomify.com/CVE-2026-81694/): openssl-encrypt before 1.4.9 Output Injection via Unsanitized Filenames in verify-usb Command (critical 9.3)
- [CVE-2026-81695](https://insights.sbomify.com/CVE-2026-81695/): openssl_encrypt before 1.4.9 Terminal Injection via key_id (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81696 and fix it if it is affected.

What it is: CVE-2026-81696 is a critical vulnerability in Jahlives Openssl Encrypt, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-81696 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-encrypt (PyPI): affected all versions; fixed in 1.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81696/ (Markdown: https://insights.sbomify.com/CVE-2026-81696/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81696
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81696
- OSV: https://osv.dev/vulnerability/CVE-2026-81696

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81696/
Summaries are generated and may contain mistakes; the official description above is the record.
