CVE-2026-81697 openssl_encrypt before 1.4.9 KDF Downgrade via CWD-relative Configuration

High 8.7 Published Updated

An attacker can downgrade encryption strength by planting a malicious configuration file in the current working directory, enabling offline brute-force attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-81697?

CVE-2026-81697 is a high-severity vulnerability in jahlives openssl_encrypt, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

openssl_encrypt (pip package openssl-encrypt) versions <= 1.4.8 contain a CWD-relative configuration file resolution flaw in crypt_settings.py, where CONFIG_FILE (originally the absolute per-user path ~/.crypt_settings.json) is reassigned at line 84 to the bare relative name 'crypt_settings.json'. As a result, the legacy Tk GUI's SettingsTab reads and writes KDF settings from crypt_settings.json in the process launch (current working) directory instead of the user's home directory. An attacker who plants a malicious crypt_settings.json (e.g. sha256:1 with all memory-hard KDFs disabled) can silently downgrade encryption performed in that GUI session to roughly one hash round, bypassing the weak-KDF preflight and enabling offline brute-force attacks against the resulting ciphertext. Fixed in 1.4.9.

Weakness: CWE-426

Which versions are affected by CVE-2026-81697?

How do I fix CVE-2026-81697?

No fix has been published for CVE-2026-81697 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-81697 being exploited?

There is no known exploitation of CVE-2026-81697 in the wild and no public exploit code.

Sources

Also known as GHSA-7j2v-g84w-m75v, GHSA-7wp9-wpj9-m7pm.

Is CVE-2026-81697 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free