{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-81697 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-81697 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-81697 is a high-severity vulnerability in jahlives openssl_encrypt, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-81697 and fix it if it is affected.\n\nWhat it is: CVE-2026-81697 is a high-severity vulnerability in jahlives openssl_encrypt, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-81697 in the wild and no public exploit code.\n\nAffected product: jahlives openssl_encrypt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-81697/ (Markdown: https://insights.sbomify.com/CVE-2026-81697/index.md)","id":"CVE-2026-81697","markdown":"https://insights.sbomify.com/CVE-2026-81697/index.md","name":"CVE-2026-81697","record":{"aliases":["GHSA-7j2v-g84w-m75v","GHSA-7wp9-wpj9-m7pm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python encryption library","requires_auth":"none","summary":"An attacker can downgrade encryption strength by planting a malicious configuration file in the current working directory, enabling offline brute-force attacks.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-426","name":"Untrusted Search Path"}],"description":"openssl_encrypt (pip package openssl-encrypt) versions \u003c= 1.4.8 contain a CWD-relative configuration file resolution flaw in crypt_settings.py, where CONFIG_FILE (originally the absolute per-user path ~/.crypt_settings.json) is reassigned at line 84 to the bare relative name 'crypt_settings.json'. As a result, the legacy Tk GUI's SettingsTab reads and writes KDF settings from crypt_settings.json in the process launch (current working) directory instead of the user's home directory. An attacker who plants a malicious crypt_settings.json (e.g. sha256:1 with all memory-hard KDFs disabled) can silently downgrade encryption performed in that GUI session to roughly one hash round, bypassing the weak-KDF preflight and enabling offline brute-force attacks against the resulting ciphertext. Fixed in 1.4.9.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"openssl_encrypt before 1.4.9 KDF Downgrade via CWD-relative Configuration","id":"CVE-2026-81697","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"openssl_encrypt before 1.4.9 Shell Injection via info command","id":"CVE-2026-81698"},"packages":[],"prev":{"headline":"openssl_encrypt before 1.4.9 Terminal Injection via info Command","id":"CVE-2026-81696"},"products":["openssl_encrypt"],"published":"2026-08-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["jahlives"]},"summary":"An attacker can downgrade encryption strength by planting a malicious configuration file in the current working directory, enabling offline brute-force attacks.","url":"https://insights.sbomify.com/CVE-2026-81697/"}