CVE-2026-81714 openssl_encrypt before 1.4.9 Plugin Signing Trust Anchor Enrollment Bypass

Critical 9.3 Published Updated

Attackers can bypass plugin signature enforcement by exploiting weak fingerprint matching to enroll malicious trust anchors, leading to arbitrary code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-81714?

CVE-2026-81714 is a critical vulnerability in Jahlives Openssl Encrypt, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

openssl_encrypt (pip: openssl-encrypt) versions <= 1.4.8 use suffix-tolerant fingerprint matching in enroll_trust_key when binding a plugin-signing trust anchor. An operator who confirms a short (forgeable, ~32-bit) GPG key id could unknowingly enroll an attacker's colliding key as a trusted anchor, which then vouches for malicious plugins under the ENFORCE signature policy. Version 1.4.9 fixes this by requiring the confirmed value to exactly match the full primary-key fingerprint (case-insensitive, whitespace-stripped).

Weakness: CWE-347

Which versions are affected by CVE-2026-81714?

1 open source package ship an affected version, including openssl-encrypt. It affects 1 product.

PackageAffectedFixed in
openssl-encrypt PyPIAll versions1.4.9

Products include Jahlives Openssl Encrypt.

How do I fix CVE-2026-81714?

Upgrade openssl-encrypt to 1.4.9 or later.

Is CVE-2026-81714 being exploited?

There is no known exploitation of CVE-2026-81714 in the wild and no public exploit code.

All Jahlives Openssl Encrypt vulnerabilities

Sources

Also known as GHSA-xg52-638v-jc5m, GHSA-xrf2-fg77-9588, PYSEC-2026-3799.

Is CVE-2026-81714 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free