CVE-2026-81715 openssl_encrypt before 1.4.9 Credential Exposure via Debug Output

High 8.7 Published Updated

Attackers can read exposed bearer tokens from debug logs in openssl_encrypt, requiring the --debug flag to be enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-81715?

CVE-2026-81715 is a high-severity vulnerability in Jahlives Openssl Encrypt, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

openssl_encrypt (pip package openssl-encrypt) versions <= 1.4.8 do not redact the keyserver bearer token passed as the positional argument to 'keyserver set-token' in the --debug argv dump, because sanitize_argv_for_debug fails to sanitize it. As a result the token is printed in cleartext to stderr under --debug (even without --unsafe-show-secrets), persisting the credential in logs and terminal history. Fixed in 1.4.9.

Weakness: CWE-532

Which versions are affected by CVE-2026-81715?

1 open source package ship an affected version, including openssl-encrypt. It affects 1 product.

PackageAffectedFixed in
openssl-encrypt PyPIAll versions1.4.9

Products include Jahlives Openssl Encrypt.

How do I fix CVE-2026-81715?

Upgrade openssl-encrypt to 1.4.9 or later.

Is CVE-2026-81715 being exploited?

There is no known exploitation of CVE-2026-81715 in the wild and no public exploit code.

All Jahlives Openssl Encrypt vulnerabilities

Sources

Also known as GHSA-h5x2-vmqf-9934, GHSA-jqqp-pf9j-889j, PYSEC-2026-3964.

Is CVE-2026-81715 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free