{"answers":{"affected":"1 open source package ship an affected version, including openssl-encrypt. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-81719 in the wild and no public exploit code.","fix":"Upgrade openssl-encrypt to 1.4.9 or later.","what":"CVE-2026-81719 is a critical code injection vulnerability in Jahlives Openssl Encrypt, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-81719 and fix it if it is affected.\n\nWhat it is: CVE-2026-81719 is a critical code injection vulnerability in Jahlives Openssl Encrypt, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-81719 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openssl-encrypt (PyPI): affected all versions; fixed in 1.4.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-81719/ (Markdown: https://insights.sbomify.com/CVE-2026-81719/index.md)","id":"CVE-2026-81719","markdown":"https://insights.sbomify.com/CVE-2026-81719/index.md","name":"CVE-2026-81719","record":{"aliases":["GHSA-587j-4r3v-cm2c","GHSA-chrm-8mrh-xgj7","PYSEC-2026-3802"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python encryption library","requires_auth":"none","summary":"Attackers can achieve arbitrary code execution by inducing users to load malicious plugins due to insufficient signature enforcement and bypassable AST checks.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"openssl_encrypt","vendor":"jahlives"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"openssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compiled and executed in the host process at import time, before the runtime sandbox is installed. The only default gate was an incomplete, bypassable AST denylist. If a user is induced to load an attacker's plugin, this results in arbitrary code execution with the privileges of the user running openssl_encrypt. Fixed in 1.4.9 by defaulting the signature policy to ENFORCE for non-built-in plugins.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"openssl_encrypt before 1.4.9 Remote Code Execution via Plugin","id":"CVE-2026-81719","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"jahlives:openssl_encrypt","products":["jahlives:openssl_encrypt"],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"openssl_encrypt before 1.4.9 Denial of Service via Unbounded Argon2","id":"CVE-2026-81720"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.9"],"introduced":["0"],"last_affected":[],"package":"openssl-encrypt","purl":"pkg:pypi/openssl-encrypt","source":"PYSEC-2026-3802"}],"prev":{"headline":"openssl_encrypt before 1.4.9 Weak Cryptographic Parameters","id":"CVE-2026-81718"},"products":["openssl_encrypt"],"published":"2026-08-27","related":[{"cvss_score":9.3,"headline":"openssl_encrypt before 1.4.9 Authentication Bypass via Recovery Slot Removal","id":"CVE-2026-81680","kev_date_added":null,"published":"2026-08-27"},{"cvss_score":9.3,"headline":"openssl_encrypt before 1.4.9 False Encryption via Cleartext Storage","id":"CVE-2026-81681","kev_date_added":null,"published":"2026-08-27"},{"cvss_score":9.3,"headline":"openssl_encrypt before 1.4.9 Text Injection via Recovery Slot Metadata","id":"CVE-2026-81685","kev_date_added":null,"published":"2026-08-27"},{"cvss_score":9.3,"headline":"openssl-encrypt before 1.4.9 Output Injection via Unsanitized Filenames in verify-usb Command","id":"CVE-2026-81694","kev_date_added":null,"published":"2026-08-27"},{"cvss_score":9.3,"headline":"openssl_encrypt before 1.4.9 Terminal Injection via key_id","id":"CVE-2026-81695","kev_date_added":null,"published":"2026-08-27"},{"cvss_score":9.3,"headline":"openssl_encrypt before 1.4.9 Terminal Injection via info Command","id":"CVE-2026-81696","kev_date_added":null,"published":"2026-08-27"},{"cvss_score":9.3,"headline":"openssl_encrypt before 1.4.9 Shell Injection via info command","id":"CVE-2026-81698","kev_date_added":null,"published":"2026-08-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["jahlives"]},"summary":"Attackers can achieve arbitrary code execution by inducing users to load malicious plugins due to insufficient signature enforcement and bypassable AST checks.","url":"https://insights.sbomify.com/CVE-2026-81719/"}