# CVE-2026-81723: NLTK before 3.10.3 Quadratic CPU Exhaustion via XMLCorpusView

> Attackers can cause denial of service in NLTK by providing malformed XML files that trigger quadratic CPU exhaustion during parsing.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-81723, ECHO-3ec1-214e-209e, GHSA-vp2x-qp44-57v7, MINI-hvrv-3qj9-5jpj, PYSEC-2026-3871, UBUNTU-CVE-2026-81723

## What is CVE-2026-81723?

CVE-2026-81723 is a medium-severity denial of service vulnerability in nltk, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLTK versions before 3.10.3 contain a quadratic CPU exhaustion vulnerability in XMLCorpusView._read_xml_fragment() that rescans accumulated XML fragments on every 1 KiB block read. Attackers can provide malformed XML corpus files to cause severe CPU consumption and denial of service through affected readers like BNCCorpusReader.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-81723?

3 open source packages ship an affected version, including nltk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.10.3 |
| `nltk` | PyPI | All versions | 3.10.3 |
| `nltk` | PyPI | All versions | 3.10.3 |

## How do I fix CVE-2026-81723?

Upgrade nltk to 3.10.3 or later.

## Is CVE-2026-81723 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-81723 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81723 and fix it if it is affected.

What it is: CVE-2026-81723 is a medium-severity denial of service vulnerability in nltk, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-81723 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.10.3
- nltk (PyPI): affected all versions; fixed in 3.10.3
- nltk (PyPI): affected all versions; fixed in 3.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81723/ (Markdown: https://insights.sbomify.com/CVE-2026-81723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81723
- OSV: https://osv.dev/vulnerability/CVE-2026-81723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81723/
Summaries are generated and may contain mistakes; the official description above is the record.
