# CVE-2026-81725: NLTK before 3.10.3 Regular Expression Denial of Service via Pl196xCorpusReader

> Attackers can cause denial of service in NLTK by supplying malformed TEI blocks that trigger quadratic CPU consumption via regex patterns.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-81725, ECHO-c4c0-fd69-5811, GHSA-8mpw-7fpc-4gqj, MINI-v5qj-7q8q-jhfc, PYSEC-2026-3752, UBUNTU-CVE-2026-81725

## What is CVE-2026-81725?

CVE-2026-81725 is a medium-severity denial of service vulnerability in nltk, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLTK before 3.10.3 contains a regular expression denial of service vulnerability in Pl196xCorpusReader that allows attackers to cause quadratic CPU consumption by supplying malformed TEI blocks with many unmatched opening tags. Attackers can exploit lazy regex patterns in the read_block method through public APIs like words() and tagged_words() to force repeated rescans and achieve near-quadratic runtime growth.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-81725?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.10.3 |
| `nltk` | PyPI | All versions | 3.10.3 |
| `nltk` | PyPI | All versions | 3.10.3 |

Products: Nltk Nltk.

## How do I fix CVE-2026-81725?

Upgrade nltk to 3.10.3 or later.

## Is CVE-2026-81725 being exploited?

There is no known exploitation of CVE-2026-81725 in the wild and no public exploit code.

## Other vulnerabilities in nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81725 and fix it if it is affected.

What it is: CVE-2026-81725 is a medium-severity denial of service vulnerability in nltk, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-81725 in the wild and no public exploit code.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.10.3
- nltk (PyPI): affected all versions; fixed in 3.10.3
- nltk (PyPI): affected all versions; fixed in 3.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81725/ (Markdown: https://insights.sbomify.com/CVE-2026-81725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81725
- OSV: https://osv.dev/vulnerability/CVE-2026-81725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81725/
Summaries are generated and may contain mistakes; the official description above is the record.
