# CVE-2026-81726: NLTK through 3.10.3 Path Traversal via Model-Artifact APIs

> Attackers can read or write files outside sandbox roots via model-artifact APIs in NLTK when pathsec is enabled.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-81726, GHSA-8mgp-746c-j5xp, PYSEC-2026-3740, UBUNTU-CVE-2026-81726, openSUSE-SU-2026:12280-1

## What is CVE-2026-81726?

CVE-2026-81726 is a high-severity path traversal vulnerability in nltk, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLTK through 3.10.3 contains a path traversal vulnerability in model-artifact APIs that bypass pathsec enforcement by using raw file operations on caller-controlled paths. Attackers can read or write files outside allowed sandbox roots through TransitionParser, AveragedPerceptron, PerceptronTagger, and maxent parameter APIs when pathsec is enabled.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-81726?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions to 3.10.3 | None |
| `nltk` | PyPI | All versions to 3.10.3 | None |
| `nltk` | PyPI | All versions | 3.10.3 |
| `python-nltk` | openSUSE:Tumbleweed | All versions | 3.10.4-1.1 |

Products: Nltk Nltk.

## How do I fix CVE-2026-81726?

Upgrade nltk to 3.10.3 or later.

## Is CVE-2026-81726 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-81726 exists.

## Other vulnerabilities in nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81726 and fix it if it is affected.

What it is: CVE-2026-81726 is a high-severity path traversal vulnerability in nltk, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-81726 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions up to 3.10.3; no fix listed
- nltk (PyPI): affected all versions up to 3.10.3; no fix listed
- nltk (PyPI): affected all versions; fixed in 3.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81726/ (Markdown: https://insights.sbomify.com/CVE-2026-81726/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81726
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81726
- OSV: https://osv.dev/vulnerability/CVE-2026-81726

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81726/
Summaries are generated and may contain mistakes; the official description above is the record.
