# CVE-2026-81852: AshAdmin ships a hardcoded CSP nonce, allowing nonce-based CSP bypass

> AshAdmin uses a hardcoded CSP nonce, allowing attackers to bypass Content-Security-Policy protections and execute inline scripts on admin pages.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** EEF-CVE-2026-81852, GHSA-whfj-rrrp-j597

## What is CVE-2026-81852?

CVE-2026-81852 is a low-severity vulnerability in ash-project ash_admin, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Use of Insufficiently Random Values vulnerability in ash-project ash_admin ships a hardcoded, publicly known CSP nonce, defeating nonce-based Content-Security-Policy protection.

When mounted without :csp_nonce_assign_key, AshAdmin.Router.ash_admin/2 defaulted the img, style, and script nonces to the literal constant ash_admin-Ed55GFnX, which AshAdmin.Layouts wrote verbatim into the nonce attribute of its inline <style> and <script> tags on every response. The value is a compile-time constant published in the repository and is never rotated per request. If an application's CSP script-src allow-lists that documented default, any HTML-injection sink on an admin page can reuse the known nonce to run inline scripts the policy was meant to block. The fix generates a fresh random nonce per request.

This issue affects ash_admin: from 0.10.8 before 1.3.1.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2026-81852?

1 open source package ship an affected version, including ash_admin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_admin` | Hex | From 0.10.8 | 1.3.1 |

## How do I fix CVE-2026-81852?

Upgrade ash_admin to 1.3.1 or later.

## Is CVE-2026-81852 being exploited?

There is no known exploitation of CVE-2026-81852 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81852 and fix it if it is affected.

What it is: CVE-2026-81852 is a low-severity vulnerability in ash-project ash_admin, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-81852 in the wild and no public exploit code.

Affected packages and fixed versions:
- ash_admin (Hex): affected from 0.10.8; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81852/ (Markdown: https://insights.sbomify.com/CVE-2026-81852/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81852
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81852
- OSV: https://osv.dev/vulnerability/CVE-2026-81852

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81852/
Summaries are generated and may contain mistakes; the official description above is the record.
