{"answers":{"affected":"1 open source package ship an affected version, including nifi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-81866 in the wild and no public exploit code.","fix":"Upgrade nifi to 2.12.0 or later.","what":"CVE-2026-81866 is a low-severity missing authorization vulnerability in Apache Nifi, published on 16 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-81866 and fix it if it is affected.\n\nWhat it is: CVE-2026-81866 is a low-severity missing authorization vulnerability in Apache Nifi, published on 16 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-81866 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nifi (Bitnami): affected from 2.9.0; fixed in 2.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-81866/ (Markdown: https://insights.sbomify.com/CVE-2026-81866/index.md)","id":"CVE-2026-81866","markdown":"https://insights.sbomify.com/CVE-2026-81866/index.md","name":"CVE-2026-81866","record":{"aliases":["BIT-nifi-2026-81866","GHSA-8c35-m833-7pmh","MINI-6fr7-ghfq-gmvm"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache NiFi","requires_auth":"high_privilege","summary":"Authenticated users can access unauthorized secrets and assets via connector configuration APIs if granular authorization is not configured.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"nifi","vendor":"apache"}],"cvss":{"score":0.5,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/E:U/S:N/AU:Y/R:U/V:C/RE:L/U:Clear","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Apache NiFi 2.9.0 through 2.11.0 provide Connector configuration update and verification REST API methods that do not enforce authorization checking on Assets and Secrets referenced in proposed configuration. Updating or verifying a Connector configuration step can apply Asset and Secret references, but framework authorization was limited to write privileges on the Connector itself. As a result of the missing authorization, an authenticated user authorized to modify a Connector, but not authorized to read a referenced Parameter Provider, could apply Secret values backed by that Parameter Provider. The same methods also accepted Asset identifiers without verifying that the Asset belonged to the Connector being configured. Apache NiFi installations that do not implement different levels of authorization across Connectors and Parameter Providers are not subject to this vulnerability, because the framework enforces write permissions on the Connector as the security boundary. Upgrading to Apache NiFi 2.12.0 is the recommended mitigation, which authorizes read access to referenced Parameter Providers and verifies Connector ownership of referenced Assets during configuration update and verification.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache NiFi: Missing Authorization for Assets and Secrets Referenced by Connector Configuration","id":"CVE-2026-81866","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:nifi","products":["apache:nifi"],"type":"missing_authorization","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Deserialization of Untrusted Data in Application Integration allows Remote Code Execution","id":"CVE-2026-81867"},"packages":[{"ecosystem":"Bitnami","fixed":["2.12.0"],"introduced":["2.9.0"],"last_affected":[],"package":"nifi","purl":"pkg:bitnami/nifi","source":"BIT-nifi-2026-81866"}],"prev":{"headline":"Information disclosure in Apache Airflow Teradata provider","id":"CVE-2026-81862"},"products":["Apache NiFi"],"published":"2026-09-16","related":[{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache NiFi","id":"CVE-2018-1309","kev_date_added":null,"published":"2018-05-23"},{"cvss_score":9.8,"headline":"Apache NiFi XSS issue in context path handling","id":"CVE-2017-15697","kev_date_added":null,"published":"2018-01-23"},{"cvss_score":9.8,"headline":"Injection in Apache NiFi","id":"CVE-2017-5636","kev_date_added":null,"published":"2017-10-19"},{"cvss_score":8.8,"headline":"Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests","id":"CVE-2026-68981","kev_date_added":null,"published":"2026-08-03"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources","id":"CVE-2023-36542","kev_date_added":null,"published":"2023-07-29"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Database Services using H2","id":"CVE-2023-34468","kev_date_added":null,"published":"2023-06-12"},{"cvss_score":8.8,"headline":"Improper Neutralization of Command Elements in Shell User Group Provider","id":"CVE-2022-33140","kev_date_added":null,"published":"2022-06-15"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can access unauthorized secrets and assets via connector configuration APIs if granular authorization is not configured.","url":"https://insights.sbomify.com/CVE-2026-81866/"}