# CVE-2026-81866: Apache NiFi: Missing Authorization for Assets and Secrets Referenced by Connector Configuration

> Authenticated users can access unauthorized secrets and assets via connector configuration APIs if granular authorization is not configured.

- **Severity:** Low 0.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/E:U/S:N/AU:Y/R:U/V:C/RE:L/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** BIT-nifi-2026-81866, GHSA-8c35-m833-7pmh, MINI-6fr7-ghfq-gmvm

## What is CVE-2026-81866?

CVE-2026-81866 is a low-severity missing authorization vulnerability in Apache Nifi, published on 16 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Apache NiFi 2.9.0 through 2.11.0 provide Connector configuration update and verification REST API methods that do not enforce authorization checking on Assets and Secrets referenced in proposed configuration. Updating or verifying a Connector configuration step can apply Asset and Secret references, but framework authorization was limited to write privileges on the Connector itself. As a result of the missing authorization, an authenticated user authorized to modify a Connector, but not authorized to read a referenced Parameter Provider, could apply Secret values backed by that Parameter Provider. The same methods also accepted Asset identifiers without verifying that the Asset belonged to the Connector being configured. Apache NiFi installations that do not implement different levels of authorization across Connectors and Parameter Providers are not subject to this vulnerability, because the framework enforces write permissions on the Connector as the security boundary. Upgrading to Apache NiFi 2.12.0 is the recommended mitigation, which authorizes read access to referenced Parameter Providers and verifies Connector ownership of referenced Assets during configuration update and verification.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-81866?

1 open source package ship an affected version, including nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nifi` | Bitnami | From 2.9.0 | 2.12.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-81866?

Upgrade nifi to 2.12.0 or later.

## Is CVE-2026-81866 being exploited?

There is no known exploitation of CVE-2026-81866 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81866 and fix it if it is affected.

What it is: CVE-2026-81866 is a low-severity missing authorization vulnerability in Apache Nifi, published on 16 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-81866 in the wild and no public exploit code.

Affected packages and fixed versions:
- nifi (Bitnami): affected from 2.9.0; fixed in 2.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81866/ (Markdown: https://insights.sbomify.com/CVE-2026-81866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81866
- OSV: https://osv.dev/vulnerability/CVE-2026-81866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81866/
Summaries are generated and may contain mistakes; the official description above is the record.
