# CVE-2026-81875: HAPI FHIR: SHCParser unbounded DEFLATE decompression causes denial of service

> Attackers can cause denial of service in applications using HAPI FHIR by sending Smart Health Card JWTs with malicious DEFLATE payloads that exhaust memory.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-3w98-rrpr-fprr, ROOT-APP-MAVEN-CVE-2026-81875

## What is CVE-2026-81875?

CVE-2026-81875 is a high-severity denial of service vulnerability in hapifhir org.hl7.fhir.core, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to version 6.9.12, SHCParser in org.hl7.fhir.r5/src/main/java/org/hl7/fhir/r5/elementmodel/SHCParser.java can consume attacker-controlled Smart Health Card JWT content whose header contains zip: "DEF" and whose small raw-DEFLATE payload expands to a very large value. SHCParser.decodeJWT() passes the decoded payload to SHCParser.inflate(), which accumulates all decompressed bytes in a ByteArrayOutputStream without an output-size limit before JSON parsing, and SHCParser.decompress() contains the same unbounded pattern. An application or validator service that accepts attacker-supplied SHC content can therefore suffer excessive heap allocation, severe garbage-collection pressure, request failure, process instability, or process termination. This issue is fixed in version 6.9.12.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification)), CWE-400 (Uncontrolled Resource Consumption), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-81875?

6 open source packages ship an affected version, including ca.uhn.hapi.fhir:org.hl7.fhir.r5, ca.uhn.hapi.fhir:org.hl7.fhir.validation and ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r5` | Maven | All versions | 6.9.12 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r5` | Maven | All versions | 6.9.12 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation` | Maven | All versions | 6.9.12 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation` | Maven | All versions | 6.9.12 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli` | Maven | All versions to 5.0.0 | None |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli` | Maven | All versions to 5.0.0 | None |

## How do I fix CVE-2026-81875?

Upgrade ca.uhn.hapi.fhir:org.hl7.fhir.r5 to 6.9.12 or later.

## Is CVE-2026-81875 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-81875 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81875 and fix it if it is affected.

What it is: CVE-2026-81875 is a high-severity denial of service vulnerability in hapifhir org.hl7.fhir.core, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-81875 exists.

Affected packages and fixed versions:
- ca.uhn.hapi.fhir:org.hl7.fhir.r5 (Maven): affected all versions; fixed in 6.9.12
- ca.uhn.hapi.fhir:org.hl7.fhir.r5 (Maven): affected all versions; fixed in 6.9.12
- ca.uhn.hapi.fhir:org.hl7.fhir.validation (Maven): affected all versions; fixed in 6.9.12
- ca.uhn.hapi.fhir:org.hl7.fhir.validation (Maven): affected all versions; fixed in 6.9.12
- ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli (Maven): affected all versions up to 5.0.0; no fix listed
- ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli (Maven): affected all versions up to 5.0.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81875/ (Markdown: https://insights.sbomify.com/CVE-2026-81875/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81875
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81875
- OSV: https://osv.dev/vulnerability/CVE-2026-81875

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81875/
Summaries are generated and may contain mistakes; the official description above is the record.
