# CVE-2026-81888: @hono/oauth-providers: OAuth state check fails open on omitted state, enabling login CSRF and forced account linking

> Attackers can bypass OAuth state validation to perform login CSRF and force account linking in applications using Hono OAuth providers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 1 Sep 2026
- **Also known as:** GHSA-fm3f-ch8h-qw8q

## What is CVE-2026-81888?

CVE-2026-81888 is a medium-severity vulnerability in honojs @hono/oauth-providers, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

@hono/oauth-providers is Authentication middleware for Hono. Prior to version 0.8.6, the built-in social login providers accept an OAuth callback even when the `state` value is absent on both sides, so the anti-CSRF check passes for a callback that never came from a genuine login attempt. This defeats the `state`-based CSRF protection under default usage. Version 0.8.6 has a patch.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-1275 (Sensitive Cookie with Improper SameSite Attribute)

## Which versions are affected by CVE-2026-81888?

2 open source packages ship an affected version, including @hono/oauth-providers.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hono/oauth-providers` | npm | All versions | 0.8.6 |
| `@hono/oauth-providers` | npm | All versions | 0.8.6 |

## How do I fix CVE-2026-81888?

Upgrade @hono/oauth-providers to 0.8.6 or later.

## Is CVE-2026-81888 being exploited?

There is no known exploitation of CVE-2026-81888 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81888 and fix it if it is affected.

What it is: CVE-2026-81888 is a medium-severity vulnerability in honojs @hono/oauth-providers, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-81888 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hono/oauth-providers (npm): affected all versions; fixed in 0.8.6
- @hono/oauth-providers (npm): affected all versions; fixed in 0.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81888/ (Markdown: https://insights.sbomify.com/CVE-2026-81888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81888
- OSV: https://osv.dev/vulnerability/CVE-2026-81888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81888/
Summaries are generated and may contain mistakes; the official description above is the record.
