# CVE-2026-81914: Apache Airflow Google provider: Google Drive query injection via unescaped file and folder names

> Attackers can inject Google Drive query clauses via unescaped file names, potentially redirecting uploads or substituting downloaded files in Airflow workflows.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-g995-5p95-2fw6, PYSEC-2026-4187

## What is CVE-2026-81914?

CVE-2026-81914 is a medium-severity code injection vulnerability in Apache Airflow Google provider, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow's Google provider built Google Drive search expressions by interpolating file and folder names directly into single-quoted string literals, without escaping the quote character that delimits them. A name containing an apostrophe therefore terminated the literal early and appended clauses of the attacker's choosing to the query.

The names are frequently not written by the Dag author. In a wildcard `gcs_to_gdrive` transfer they come from the source bucket listing, so anyone able to create objects in that bucket controls them — typically an external data producer or an ingest-only service account, a different trust principal from the Dag author. An injected clause can broaden the match and so steer which file or folder the hook resolves: an upload can be directed into a folder the attacker named, and, because downloads select the most recently modified match, a download can return a file they placed rather than the one the Dag asked for.

Affects deployments passing externally-sourced names to the Google Drive hook, including wildcard `gcs_to_gdrive` transfers from buckets writable by less-trusted principals. Users are advised to upgrade to `apache-airflow-providers-google` `22.6.0` or later, which escapes quote and backslash characters in every value interpolated into a Drive query.

Weakness: CWE-943 (Improper Neutralization of Special Elements in Data Query Logic)

## Which versions are affected by CVE-2026-81914?

1 open source package ship an affected version, including apache-airflow-providers-google. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-google` | PyPI | All versions | 22.6.0 |

Products: Apache Apache-Airflow-Providers-Google.

## How do I fix CVE-2026-81914?

Upgrade apache-airflow-providers-google to 22.6.0 or later.

## Is CVE-2026-81914 being exploited?

There is no known exploitation of CVE-2026-81914 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Google provider

- [CVE-2023-25691](https://insights.sbomify.com/CVE-2023-25691/): Apache Airflow Google Provider: Google Cloud Sql Provider Remote Command Execution (critical 9.8)
- [CVE-2026-49297](https://insights.sbomify.com/CVE-2026-49297/): Apache Airflow Google provider allows path traversal through GCS object names (high 8.1)
- [CVE-2026-45361](https://insights.sbomify.com/CVE-2026-45361/): Apache Airflow providers-google's `ComputeEngineSSHHook` disables SSH host-key verification by default (high 8.1)
- [CVE-2023-25692](https://insights.sbomify.com/CVE-2023-25692/): Apache Airflow Google Provider: Google Cloud Sql Provider Denial Of Service (high 7.5)
- [CVE-2026-68868](https://insights.sbomify.com/CVE-2026-68868/): Missing authorization in Apache Airflow Google provider (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-81914 and fix it if it is affected.

What it is: CVE-2026-81914 is a medium-severity code injection vulnerability in Apache Airflow Google provider, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-81914 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-google (PyPI): affected all versions; fixed in 22.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-81914/ (Markdown: https://insights.sbomify.com/CVE-2026-81914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-81914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-81914
- OSV: https://osv.dev/vulnerability/CVE-2026-81914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-81914/
Summaries are generated and may contain mistakes; the official description above is the record.
