CVE-2026-8200 Schema validation log messages may not redact user data
Attackers with log access can view unredacted user data in MongoDB server logs when schema validation fails during updates or inserts.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-8200?
CVE-2026-8200 is a medium-severity vulnerability in Mongodb Mongodb, published on 13 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
When schema validation is enabled on a collection and an update or insert would violate the collection's schema, the local server log message generated may not have all user data redacted.
This issue impacts MongoDB Server v7.0 versions prior to 7.0.34, v8.0 versions prior to 8.0.23, v8.2 versions prior to 8.2.9 and v8.3 versions prior to 8.3.2.
Weakness: CWE-532
Which versions are affected by CVE-2026-8200?
1 open source package ship an affected version, including mongodb. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mongodb Bitnami | From 7.0.0 | 7.0.34, 8.0.23, 8.2.9, 8.3.2 |
Products include Mongodb Mongodb.
How do I fix CVE-2026-8200?
Upgrade mongodb to a fixed version for your release line: 7.0.34, 8.0.23, 8.2.9 or 8.3.2.
Is CVE-2026-8200 being exploited?
There is no known exploitation of CVE-2026-8200 in the wild and no public exploit code.
Other vulnerabilities in Mongodb Mongodb
- CVE-2025-14847 MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency
- CVE-2026-82067 Auth bypass in MongoDB Server
- CVE-2026-13072 MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption
- CVE-2017-15535 Denial of service in n/a
- CVE-2026-18691 Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure
Sources
Also known as BIT-mongodb-2026-8200, GHSA-595w-9635-gr7c, MINI-2jxv-f9mf-rm4x, MINI-4m24-pp3x-rxph, MINI-vqhv-wrgg-x675, UBUNTU-CVE-2026-8200.