# CVE-2026-8203: Concrete CMS 9.5.0 and below has Stored XSS on the height parameter

> Attackers with editor privileges can inject malicious JavaScript via the height parameter, leading to session hijacking or credential theft for visitors.

- **Severity:** High 7.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 May 2026
- **Updated:** 22 May 2026
- **Also known as:** GHSA-9v2g-37mp-qpxf

## What is CVE-2026-8203?

CVE-2026-8203 is a high-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Concrete CMS 9.5.0 and below has Stored XSS on the height parameter. The controller does not validate or sanitize $height. Any user with editor privileges can inject malicious JavaScript that executes in the context of any visitor's browser, potentially leading to session hijacking, credential theft, or other malicious actions. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 7.3 with vector CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N. Thanks Alfin Joseph for reporting.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-8203?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 9.5.1 |
| `concrete5/concrete5` | Packagist | All versions | 9.5.1 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2026-8203?

Upgrade concrete5/concrete5 to 9.5.1 or later.

## Is CVE-2026-8203 being exploited?

There is no known exploitation of CVE-2026-8203 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8203 and fix it if it is affected.

What it is: CVE-2026-8203 is a high-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 21 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-8203 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.1
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8203/ (Markdown: https://insights.sbomify.com/CVE-2026-8203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8203
- OSV: https://osv.dev/vulnerability/CVE-2026-8203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8203/
Summaries are generated and may contain mistakes; the official description above is the record.
