# CVE-2026-82049: tarfile extraction filters allow file modification and content disclosure via hard link to symlink

> Attackers can craft tar archives to modify permissions or disclose contents of files outside the extraction directory via hard link to symlink tricks.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 11 Oct 2026
- **Also known as:** ALPINE-CVE-2026-82049, AZL-101784, AZL-101832, BELL-CVE-2026-82049, BIT-libpython-2026-82049, BIT-python-2026-82049, BIT-python-min-2026-82049, CLSA-2026-1789662396, CLSA-2026-1789719542, CLSA-2026-1789719876, CLSA-2026-1789736914, CLSA-2026-1789749056, CLSA-2026-1792411096, DEBIAN-CVE-2026-82049, ECHO-ce85-5a2e-16be, GHSA-ghff-gcpf-9r9p, MINI-gp7v-r49g-fjvx, MINI-hrc8-58gw-42wj, MINI-m4vj-4h7j-c7w5, MINI-pmjg-g8q5-5c97, MINI-x6vr-cm4w-9x57, PSF-0000-CVE-2026-82049, PSF-2026-41, ROOT-OS-DEBIAN-13-CVE-2026-82049, SUSE-SU-2026:4738-1, SUSE-SU-2026:4904-1, UBUNTU-CVE-2026-82049

## What is CVE-2026-82049?

CVE-2026-82049 is a high-severity path traversal vulnerability in CPython, published on 14 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In CPython 3.13 and earlier, the tarfile module's data and tar extraction filters are vulnerable to crafted archives containing a hard link to a symbolic link. Such archives may cause extraction to modify the permissions or modification time of a file outside the destination directory, or expose the contents of that file within the extracted tree.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-82049?

3 open source packages ship an affected version, including libpython, python and python-min.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | All versions | 3.10.22, 3.11.17, 3.12.15, 3.13.16 |
| `python` | Bitnami | All versions | 3.10.22, 3.11.17, 3.12.15, 3.13.16 |
| `python-min` | Bitnami | All versions | 3.10.22, 3.11.17, 3.12.15, 3.13.16 |
| `python` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 2.7.18-150000.136.1 |
| `python-base` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 2.7.18-150000.136.1 |
| `python` | SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 2.7.18-33.93.1 |
| `python-base` | SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 2.7.18-33.93.1 |
| `python-doc` | SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 2.7.18-33.93.1 |
| `python` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 2.7.18-33.93.1 |
| `python-base` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 2.7.18-33.93.1 |
| `python-doc` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 2.7.18-33.93.1 |

## How do I fix CVE-2026-82049?

Upgrade libpython to a fixed version for your release line: 3.10.22, 3.11.17, 3.12.15 or 3.13.16.

## Is CVE-2026-82049 being exploited?

There is no known exploitation of CVE-2026-82049 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82049 and fix it if it is affected.

What it is: CVE-2026-82049 is a high-severity path traversal vulnerability in CPython, published on 14 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-82049 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpython (Bitnami): affected all versions; fixed in 3.10.22, 3.11.17, 3.12.15, 3.13.16
- python (Bitnami): affected all versions; fixed in 3.10.22, 3.11.17, 3.12.15, 3.13.16
- python-min (Bitnami): affected all versions; fixed in 3.10.22, 3.11.17, 3.12.15, 3.13.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82049/ (Markdown: https://insights.sbomify.com/CVE-2026-82049/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82049
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82049
- OSV: https://osv.dev/vulnerability/CVE-2026-82049

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82049/
Summaries are generated and may contain mistakes; the official description above is the record.
