# CVE-2026-82061: Use-After-Free in MongoDB Server Query Execution Memory Tracking Subsystem Leads to Denial of Service

> An authenticated user can trigger a use-after-free in MongoDB's memory tracking, causing a server crash and denial of service.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** BIT-mongodb-2026-82061, GHSA-5pfw-53c7-27v7, MINI-3x7w-9579-m3r8, UBUNTU-CVE-2026-82061

## What is CVE-2026-82061?

CVE-2026-82061 is a high-severity use after free vulnerability in Mongodb Mongodb, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A use-after-free security issue exists in the server's query execution memory tracking subsystem. An authenticated user with read privileges can trigger a write to freed heap memory through a sequence of standard database commands, leading to server process crash or potential memory corruption. No user interaction is required.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-82061?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 8.3.0 | 8.3.9 |

Products: Mongodb Mongodb.

## How do I fix CVE-2026-82061?

Upgrade mongodb to 8.3.9 or later.

## Is CVE-2026-82061 being exploited?

There is no known exploitation of CVE-2026-82061 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82061 and fix it if it is affected.

What it is: CVE-2026-82061 is a high-severity use after free vulnerability in Mongodb Mongodb, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82061 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 8.3.0; fixed in 8.3.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82061/ (Markdown: https://insights.sbomify.com/CVE-2026-82061/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82061
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82061
- OSV: https://osv.dev/vulnerability/CVE-2026-82061

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82061/
Summaries are generated and may contain mistakes; the official description above is the record.
