# CVE-2026-82230: Apache bRPC: Stack Exhaustion via Unbounded Recursion in mcpack2pb Parser


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-5pph-8c9p-w8p3

## What is CVE-2026-82230?

CVE-2026-82230 is a high-severity vulnerability in Apache bRPC, published on 21 Oct 2026. 

### Official description

Uncontrolled recursion in the mcpack2pb component in Apache bRPC (version < 1.18.0) on all platforms allows remote attackers to make the server crash via sending deeply nested mcpack data.

Root Cause:
The bRPC mcpack2pb parser (used to serve nshead_mcpack / ubrpc / public_pbrpc requests) recursively parses nested objects and arrays without any depth limit. For a protobuf message that references itself (e.g. a repeated message field), the generated parser recurses once per nesting level of the incoming mcpack object. A deeply nested request makes the recursion grow unbounded, overflow the stack and crash the process.

Affected Scenarios:
Use bRPC server with a recursive-schema protobuf message to serve nshead_mcpack / ubrpc / public_pbrpc requests from untrusted network.

How to Fix:
(Choose one of the following options)
1. Upgrade bRPC to version 1.18.0, which fixes this issue.
2. Apply this patch: https://github.com/apache/brpc/pull/3499

Note:
No matter which option you choose, you should know that the fix enforces the documented parsing depth limit MAX_DEPTH (128) on the parse path, the same limit the serializer already applies. If your requests contain mcpack messages nested deeper than 128 levels, the request will be failed after applying the fix.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-82230?


## How do I fix CVE-2026-82230?

No fix has been published for CVE-2026-82230 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-82230 being exploited?

There is no known exploitation of CVE-2026-82230 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82230 and fix it if it is affected.

What it is: CVE-2026-82230 is a high-severity vulnerability in Apache bRPC, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-82230 in the wild and no public exploit code.

Affected product: Apache bRPC. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82230/ (Markdown: https://insights.sbomify.com/CVE-2026-82230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82230
- OSV: https://osv.dev/vulnerability/CVE-2026-82230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82230/
Summaries are generated and may contain mistakes; the official description above is the record.
