{"answers":{"affected":"2 open source packages ship an affected version, including gix-packetline.","exploited":"There is no known exploitation of CVE-2026-82250 in the wild and no public exploit code.","fix":"Upgrade gix-packetline to 0.21.5 or later.","what":"CVE-2026-82250 is a high-severity denial of service vulnerability in GitoxideLabs gitoxide, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-82250 and fix it if it is affected.\n\nWhat it is: CVE-2026-82250 is a high-severity denial of service vulnerability in GitoxideLabs gitoxide, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-82250 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gix-packetline (crates.io): affected all versions; fixed in 0.21.5\n- gix-packetline (crates.io): affected all versions; fixed in 0.21.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82250/ (Markdown: https://insights.sbomify.com/CVE-2026-82250/index.md)","id":"CVE-2026-82250","markdown":"https://insights.sbomify.com/CVE-2026-82250/index.md","name":"CVE-2026-82250","record":{"aliases":["AZL-98418","AZL-98430","DEBIAN-CVE-2026-82250","GHSA-2vh6-hw4j-32ww","GHSA-69hq-g659-8g9f","MINI-885f-wm4r-jvr6","UBUNTU-CVE-2026-82250"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Gitoxide library","requires_auth":"none","summary":"A malicious Git server can cause a client crash via crafted side-band packets in the gix-packetline library, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-191","name":"Integer Underflow (Wrap or Wraparound)"}],"description":"gitoxide gix-packetline versions before 0.21.5 contain a panic vulnerability in the TextRef implementation that occurs when processing side-band packet lines with empty payloads. A malicious Git server can send a crafted side-band packet to trigger an index out of bounds panic, aborting the client process during fetch operations without authentication.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"gitoxide gix-packetline before 0.21.5 Denial of Service","id":"CVE-2026-82250","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"gitoxide before 0.52.1 Path Traversal via Submodule Name","id":"CVE-2026-82251"},"packages":[{"ecosystem":"crates.io","fixed":["0.21.5"],"introduced":["0"],"last_affected":[],"package":"gix-packetline","purl":null,"source":"GHSA-2vh6-hw4j-32ww"},{"ecosystem":"crates.io","fixed":["0.21.5"],"introduced":["0"],"last_affected":[],"package":"gix-packetline","purl":"pkg:cargo/gix-packetline","source":"GHSA-2vh6-hw4j-32ww"}],"prev":{"headline":"gitoxide before 0.38.2 Credential Helper Protocol Field Injection","id":"CVE-2026-82249"},"products":["gitoxide"],"published":"2026-08-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-28","vendors":["GitoxideLabs"]},"summary":"A malicious Git server can cause a client crash via crafted side-band packets in the gix-packetline library, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2026-82250/"}