# CVE-2026-82252: gitoxide before 0.52.1 Repository Boundary Violation via symlinked .gitmodules

> Attackers can inject malicious submodule metadata by symlinking .gitmodules, potentially leading to arbitrary file reads or code execution.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 29 Aug 2026
- **Also known as:** AZL-98415, AZL-98427, DEBIAN-CVE-2026-82252, GHSA-pg4w-g64p-qwhj, GHSA-wj8r-8wwg-mq4f, MINI-p547-w83f-gw49, UBUNTU-CVE-2026-82252

## What is CVE-2026-82252?

CVE-2026-82252 is a high-severity path traversal vulnerability in GitoxideLabs gitoxide, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

gitoxide before 0.52.1 follows symlinks when reading the worktree .gitmodules file, allowing attackers to inject out-of-repository bytes into submodule metadata. Attackers can create a malicious repository with a symlinked .gitmodules pointing outside the repository tree, causing gitoxide to parse arbitrary external files as submodule configuration and expose attacker-controlled name, path, and url values.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-82252?

4 open source packages ship an affected version, including gitoxide and gix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitoxide` | crates.io | All versions | 0.52.1 |
| `gitoxide` | crates.io | All versions | 0.52.1 |
| `gix` | crates.io | All versions | 0.83.0 |
| `gix` | crates.io | All versions | 0.83.0 |

## How do I fix CVE-2026-82252?

Upgrade gitoxide to 0.52.1 or later.

## Is CVE-2026-82252 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82252 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82252 and fix it if it is affected.

What it is: CVE-2026-82252 is a high-severity path traversal vulnerability in GitoxideLabs gitoxide, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82252 exists.

Affected packages and fixed versions:
- gitoxide (crates.io): affected all versions; fixed in 0.52.1
- gitoxide (crates.io): affected all versions; fixed in 0.52.1
- gix (crates.io): affected all versions; fixed in 0.83.0
- gix (crates.io): affected all versions; fixed in 0.83.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82252/ (Markdown: https://insights.sbomify.com/CVE-2026-82252/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82252
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82252
- OSV: https://osv.dev/vulnerability/CVE-2026-82252

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82252/
Summaries are generated and may contain mistakes; the official description above is the record.
