# CVE-2026-82254: gitoxide before 0.69.0 Denial of Service via gix-pack

> Attackers can cause denial of service in gitoxide by sending crafted pack data during clone or fetch operations, triggering panics or out-of-memory kills.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** AZL-98412, AZL-98424, DEBIAN-CVE-2026-82254, GHSA-5v2g-4955-9qfh, GHSA-x494-mj8g-cj27, MINI-52vw-5q48-2cff, UBUNTU-CVE-2026-82254

## What is CVE-2026-82254?

CVE-2026-82254 is a high-severity denial of service vulnerability in GitoxideLabs gitoxide, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

gitoxide before 0.69.0 contains unchecked array indexing in delta application and uncapped allocation from attacker-controlled size headers in gix-pack. Attackers can send crafted pack data during clone or fetch operations to trigger panics or out-of-memory process kills.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-82254?

2 open source packages ship an affected version, including gix-pack.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gix-pack` | crates.io | All versions | 0.69.0 |
| `gix-pack` | crates.io | All versions | 0.69.0 |

## How do I fix CVE-2026-82254?

Upgrade gix-pack to 0.69.0 or later.

## Is CVE-2026-82254 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82254 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82254 and fix it if it is affected.

What it is: CVE-2026-82254 is a high-severity denial of service vulnerability in GitoxideLabs gitoxide, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82254 exists.

Affected packages and fixed versions:
- gix-pack (crates.io): affected all versions; fixed in 0.69.0
- gix-pack (crates.io): affected all versions; fixed in 0.69.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82254/ (Markdown: https://insights.sbomify.com/CVE-2026-82254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82254
- OSV: https://osv.dev/vulnerability/CVE-2026-82254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82254/
Summaries are generated and may contain mistakes; the official description above is the record.
