# CVE-2026-82260: SvelteKit before 2.52.2 Memory Exhaustion via Remote Form Deserialization

> Attackers can crash SvelteKit servers via memory exhaustion in remote form deserialization when experimental features are enabled.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-33c7-c62f-7cc2, GHSA-vrhm-gvg7-fpcf

## What is CVE-2026-82260?

CVE-2026-82260 is a high-severity denial of service vulnerability in sveltejs kit, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SvelteKit (@sveltejs/kit) versions >=2.49.0 and <=2.52.1 with experimental remote functions (experimental.remoteFunctions) and form enabled contain a memory exhaustion vulnerability in remote form deserialization. Malformed form data can cause excessive memory allocation, crashing the server process and resulting in denial of service. Fixed in 2.52.2.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-82260?

2 open source packages ship an affected version, including @sveltejs/kit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sveltejs/kit` | npm | From 2.49.0 | 2.52.2 |
| `@sveltejs/kit` | npm | From 2.49.0 | 2.52.2 |

Products: Svelte Sveltekit.

## How do I fix CVE-2026-82260?

Upgrade @sveltejs/kit to 2.52.2 or later.

## Is CVE-2026-82260 being exploited?

There is no known exploitation of CVE-2026-82260 in the wild and no public exploit code.

## Other vulnerabilities in sveltejs kit

- [CVE-2023-29008](https://insights.sbomify.com/CVE-2023-29008/): SvelteKit framework has Insufficient CSRF protection for CORS requests (high 8.8)
- [CVE-2023-29003](https://insights.sbomify.com/CVE-2023-29003/): SvelteKit has Insufficient Cross-Site Request Forgery Protection (high 8.8)
- [CVE-2026-82259](https://insights.sbomify.com/CVE-2026-82259/): SvelteKit 2.49.0 before 2.53.3 Denial of Service via form (high 8.7)
- [CVE-2026-82261](https://insights.sbomify.com/CVE-2026-82261/): SvelteKit before 2.52.2 CPU Exhaustion via Remote Form Deserialization (high 8.7)
- [CVE-2026-82256](https://insights.sbomify.com/CVE-2026-82256/): SvelteKit before 2.69.1 Denial of Service via Remote Form (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82260 and fix it if it is affected.

What it is: CVE-2026-82260 is a high-severity denial of service vulnerability in sveltejs kit, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82260 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sveltejs/kit (npm): affected from 2.49.0; fixed in 2.52.2
- @sveltejs/kit (npm): affected from 2.49.0; fixed in 2.52.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82260/ (Markdown: https://insights.sbomify.com/CVE-2026-82260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82260
- OSV: https://osv.dev/vulnerability/CVE-2026-82260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82260/
Summaries are generated and may contain mistakes; the official description above is the record.
