# CVE-2026-82310: Apache Airflow FAB provider: FAB auth manager: deactivated users retain and renew Core API JWT access

> Deactivated users retain access via unexpired JWT tokens, bypassing administrative containment in Apache Airflow FAB provider deployments.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-FC44731, GHSA-vj39-hwrh-p32g

## What is CVE-2026-82310?

CVE-2026-82310 is a high-severity authentication bypass vulnerability in Apache Airflow FAB provider, published on 16 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Apache Airflow FAB provider: deactivating a user account does not stop tokens issued to that account before deactivation. Password authentication correctly rejects the disabled account, but the Core API continues to accept an existing, unexpired token naming it, and lets that token mint a replacement — so the account keeps its role-scoped access indefinitely after an administrator has disabled it. The user replays their own legitimate credential; no signature forgery or privilege escalation is involved, and the access stays within the roles the account already held.

Affects deployments using Airflow 3 with the FAB auth manager and Core API token authentication, where an administrator deactivates an account whose row remains in the database and whose previously issued token has not expired. The trigger is administrative deactivation as a containment action, which silently fails to contain.

Users of apache-airflow-providers-fab are recommended to upgrade to version 3.9.0 or later, which rejects tokens naming a deactivated account.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-82310?

It affects 1 product.


Products: Apache Apache-Airflow-Providers-Fab.

## How do I fix CVE-2026-82310?

Upgrade to a fixed version.

## Is CVE-2026-82310 being exploited?

There is no known exploitation of CVE-2026-82310 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow FAB provider

- [CVE-2026-82311](https://insights.sbomify.com/CVE-2026-82311/): Security feature bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2026-59243](https://insights.sbomify.com/CVE-2026-59243/): Auth bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2024-42447](https://insights.sbomify.com/CVE-2024-42447/): Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow (critical 9.8)
- [CVE-2026-86462](https://insights.sbomify.com/CVE-2026-86462/): Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions (critical 9.1)
- [CVE-2026-75156](https://insights.sbomify.com/CVE-2026-75156/): Auth bypass in Apache Airflow FAB provider (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82310 and fix it if it is affected.

What it is: CVE-2026-82310 is a high-severity authentication bypass vulnerability in Apache Airflow FAB provider, published on 16 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82310 in the wild and no public exploit code.

Affected product: Apache Airflow FAB provider. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82310/ (Markdown: https://insights.sbomify.com/CVE-2026-82310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82310
- OSV: https://osv.dev/vulnerability/CVE-2026-82310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82310/
Summaries are generated and may contain mistakes; the official description above is the record.
