# CVE-2026-82333: multer vulnerable to Denial of Service via oversized array index in field names

> Attackers can cause denial of service in Node.js applications using multer by sending crafted multipart requests that block the event loop.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** CLEANSTART-2026-RK66393, CLSA-2026-1790609063, ECHO-39b2-3209-49fe, GHSA-535w-7cp7-47q4, MINI-65vv-vh5c-9v3j, MINI-9339-w9fg-2xwq, MINI-rp5j-g5gh-x3mf, ROOT-APP-NPM-CVE-2026-82333

## What is CVE-2026-82333?

CVE-2026-82333 is a high-severity denial of service vulnerability in multer, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

multer is a middleware for handling multipart/form-data in Node.js. A small multipart request with two specially crafted text field names can make multer's field parser synchronously iterate a maximum-length sparse array, blocking the event loop so the process cannot handle other requests. A large numeric array index in the first field allocates a maximum-length sparse array, and a second field with a non-numeric key then triggers a full-length iteration inside the append-field dependency. All versions before 2.3.0 are affected, and this is a remotely triggerable denial of service. multer 2.3.0 adds an opt-in fieldArrayIndexLimit option that rejects oversized array indexes. Upgrade to multer 2.3.0 and set limits.fieldArrayIndexLimit to the largest array index your application needs to remediate.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-82333?

2 open source packages ship an affected version, including multer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multer` | npm | All versions | 2.3.0 |
| `multer` | npm | All versions | 2.3.0 |

Products: Expressjs Multer.

## How do I fix CVE-2026-82333?

Upgrade multer to 2.3.0 or later.

## Is CVE-2026-82333 being exploited?

There is no known exploitation of CVE-2026-82333 in the wild and no public exploit code.

## Other vulnerabilities in multer

- [CVE-2026-3520](https://insights.sbomify.com/CVE-2026-3520/): Multer vulnerable to Denial of Service via uncontrolled recursion (high 8.7)
- [CVE-2026-2359](https://insights.sbomify.com/CVE-2026-2359/): Multer vulnerable to Denial of Service via resource exhaustion (high 8.7)
- [CVE-2026-3304](https://insights.sbomify.com/CVE-2026-3304/): Multer vulnerable to Denial of Service via incomplete cleanup (high 8.7)
- [CVE-2026-77037](https://insights.sbomify.com/CVE-2026-77037/): multer vulnerable to Denial of Service via file descriptor leak on aborted uploads (high 7.5)
- [CVE-2026-77078](https://insights.sbomify.com/CVE-2026-77078/): multer vulnerable to Denial of Service via crafted multipart field names (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82333 and fix it if it is affected.

What it is: CVE-2026-82333 is a high-severity denial of service vulnerability in multer, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82333 in the wild and no public exploit code.

Affected packages and fixed versions:
- multer (npm): affected all versions; fixed in 2.3.0
- multer (npm): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82333/ (Markdown: https://insights.sbomify.com/CVE-2026-82333/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82333
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82333
- OSV: https://osv.dev/vulnerability/CVE-2026-82333

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82333/
Summaries are generated and may contain mistakes; the official description above is the record.
