# CVE-2026-82377: Apache Roller: Missing weblog authorization in XML-RPC Blogger/MetaWeblog handlers

> Authenticated users can read, modify, or delete other users' weblog content via XML-RPC APIs if the feature is enabled.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-crwh-hjp8-p7q9

## What is CVE-2026-82377?

CVE-2026-82377 is a critical missing authorization vulnerability in Apache Roller, published on 28 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Missing Authorization in Apache Roller 6.1.5 allows an authenticated user to read, modify, or delete weblog content belonging to other weblogs through the legacy XML-RPC Blogger and MetaWeblog APIs, because the handlers authenticate the caller but do not verify the caller's permission on the weblog or entry actually affected. Only installations that enable the non-default global XML-RPC setting are affected; the per-weblog API flag defaults to enabled for UI-created weblogs. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which applies an explicit per-method permission check, or to keep the XML-RPC feature disabled.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-82377?


## How do I fix CVE-2026-82377?

No fix has been published for CVE-2026-82377 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-82377 being exploited?

There is no known exploitation of CVE-2026-82377 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82377 and fix it if it is affected.

What it is: CVE-2026-82377 is a critical missing authorization vulnerability in Apache Roller, published on 28 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82377 in the wild and no public exploit code.

Affected product: Apache Roller. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82377/ (Markdown: https://insights.sbomify.com/CVE-2026-82377/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82377
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82377
- OSV: https://osv.dev/vulnerability/CVE-2026-82377

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82377/
Summaries are generated and may contain mistakes; the official description above is the record.
