{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-82378 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-82378 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-82378 is a critical authentication bypass vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-82378 and fix it if it is affected.\n\nWhat it is: CVE-2026-82378 is a critical authentication bypass vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-82378 in the wild and no public exploit code.\n\nAffected product: Apache Roller. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82378/ (Markdown: https://insights.sbomify.com/CVE-2026-82378/index.md)","id":"CVE-2026-82378","markdown":"https://insights.sbomify.com/CVE-2026-82378/index.md","name":"CVE-2026-82378","record":{"aliases":["GHSA-c34v-mgwv-92x6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Roller blog","requires_auth":"none","summary":"Unauthenticated attackers can bind OAuth tokens to arbitrary admin accounts if site-wide consumers are configured, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Incorrect Authorization in the OAuth 1.0a authorization endpoint of Apache Roller 6.1.5 allows an unauthenticated remote attacker who learns an outstanding request token for a configured site-wide consumer to bind that token to an arbitrary user account, including an administrator, by submitting an unsigned authorization request. The endpoint derives the authorizing identity from a request-supplied value rather than the authenticated session. Only installations that configure an OAuth 1.0a site-wide consumer are affected, and exploitation requires knowledge of one of its outstanding request tokens. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which binds authorization to the logged-in session.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache Roller: OAuth authorization endpoint trusts request-supplied identity","id":"CVE-2026-82378","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Apache Roller: WSSE digest authentication headers can be replayed","id":"CVE-2026-82379"},"packages":[],"prev":{"headline":"Apache Roller: Missing weblog authorization in XML-RPC Blogger/MetaWeblog handlers","id":"CVE-2026-82377"},"products":["Apache Roller"],"published":"2026-09-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["Apache Software Foundation"]},"summary":"Unauthenticated attackers can bind OAuth tokens to arbitrary admin accounts if site-wide consumers are configured, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2026-82378/"}