# CVE-2026-82378: Apache Roller: OAuth authorization endpoint trusts request-supplied identity

> Unauthenticated attackers can bind OAuth tokens to arbitrary admin accounts if site-wide consumers are configured, requiring an upgrade to fix.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-c34v-mgwv-92x6

## What is CVE-2026-82378?

CVE-2026-82378 is a critical authentication bypass vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Incorrect Authorization in the OAuth 1.0a authorization endpoint of Apache Roller 6.1.5 allows an unauthenticated remote attacker who learns an outstanding request token for a configured site-wide consumer to bind that token to an arbitrary user account, including an administrator, by submitting an unsigned authorization request. The endpoint derives the authorizing identity from a request-supplied value rather than the authenticated session. Only installations that configure an OAuth 1.0a site-wide consumer are affected, and exploitation requires knowledge of one of its outstanding request tokens. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which binds authorization to the logged-in session.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-82378?


## How do I fix CVE-2026-82378?

No fix has been published for CVE-2026-82378 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-82378 being exploited?

There is no known exploitation of CVE-2026-82378 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82378 and fix it if it is affected.

What it is: CVE-2026-82378 is a critical authentication bypass vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82378 in the wild and no public exploit code.

Affected product: Apache Roller. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82378/ (Markdown: https://insights.sbomify.com/CVE-2026-82378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82378
- OSV: https://osv.dev/vulnerability/CVE-2026-82378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82378/
Summaries are generated and may contain mistakes; the official description above is the record.
