# CVE-2026-82379: Apache Roller: WSSE digest authentication headers can be replayed

> Attackers can replay captured WSSE headers to bypass authentication and gain AtomPub authority in Apache Roller installations using non-default WSSE configuration.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-4jqc-cjj3-x26w

## What is CVE-2026-82379?

CVE-2026-82379 is a high-severity authentication bypass vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authentication Bypass by Capture-replay in Apache Roller 6.1.5 allows an attacker who captures a valid WSSE digest authentication header to replay it and gain the victim's AtomPub authority, because the authentication does not enforce nonce uniqueness or timestamp freshness. Only installations that enable the non-default AtomPub API with WSSE authentication and plaintext-compatible password storage are affected. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which removes WSSE as an AtomPub authentication method; existing installations configured for WSSE fail closed until an administrator explicitly selects a supported authentication method.

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2026-82379?


## How do I fix CVE-2026-82379?

No fix has been published for CVE-2026-82379 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-82379 being exploited?

There is no known exploitation of CVE-2026-82379 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82379 and fix it if it is affected.

What it is: CVE-2026-82379 is a high-severity authentication bypass vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82379 in the wild and no public exploit code.

Affected product: Apache Roller. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82379/ (Markdown: https://insights.sbomify.com/CVE-2026-82379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82379
- OSV: https://osv.dev/vulnerability/CVE-2026-82379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82379/
Summaries are generated and may contain mistakes; the official description above is the record.
