CVE-2026-82382 Apache Roller: Reflected cross-site scripting in the frontpage directory parameter

Medium 6.1 Published Updated

Remote attackers can execute arbitrary scripts in victims' browsers via a crafted link in Apache Roller weblogs using the bundled frontpage theme.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-82382?

CVE-2026-82382 is a medium-severity cross-site scripting vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in Apache Roller 6.1.5 allows a remote attacker to perform reflected cross-site scripting against a visitor to a weblog using the bundled frontpage theme, by supplying a crafted blog-directory parameter that the directory page reflects without proper escaping. This affects only weblogs that use the bundled frontpage theme, and a victim must follow a crafted link for the script to execute. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which validates and contextually escapes the reflected parameter.

Weakness: CWE-79

Which versions are affected by CVE-2026-82382?

How do I fix CVE-2026-82382?

No fix has been published for CVE-2026-82382 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-82382 being exploited?

There is no known exploitation of CVE-2026-82382 in the wild and no public exploit code.

Sources

Also known as GHSA-j58r-vr8w-6j93.

Is CVE-2026-82382 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free