# CVE-2026-82387: Apache Roller: Stored cross-site scripting via uploaded media content type

> Attackers with upload rights can store malicious scripts in media files, leading to code execution when victims view them in enabled installations.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-cp7g-8wv7-92w2

## What is CVE-2026-82387?

CVE-2026-82387 is a medium-severity cross-site scripting vulnerability in Apache Roller, published on 28 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in Apache Roller 6.1.5 allows a user with media-upload rights to store active content on Roller's origin, because the media upload feature trusts the upload-supplied content type and serves the stored file back with that type. A victim who opens the uploaded file executes the stored script. Media uploads are disabled by default; only installations that enable them are affected, and the shipped type restrictions do not block active content once uploads are on. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which derives the stored type from file content and serves non-image media as a download.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-82387?


## How do I fix CVE-2026-82387?

No fix has been published for CVE-2026-82387 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-82387 being exploited?

There is no known exploitation of CVE-2026-82387 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82387 and fix it if it is affected.

What it is: CVE-2026-82387 is a medium-severity cross-site scripting vulnerability in Apache Roller, published on 28 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-82387 in the wild and no public exploit code.

Affected product: Apache Roller. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82387/ (Markdown: https://insights.sbomify.com/CVE-2026-82387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82387
- OSV: https://osv.dev/vulnerability/CVE-2026-82387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82387/
Summaries are generated and may contain mistakes; the official description above is the record.
