{"answers":{"affected":"4 open source packages ship an affected version, including pnpm.","exploited":"There is no known exploitation of CVE-2026-82393 in the wild and no public exploit code.","fix":"Upgrade pnpm to a fixed version for your release line: 10.34.5 or 11.11.0.","what":"CVE-2026-82393 is a high-severity path traversal vulnerability in pnpm, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-82393 and fix it if it is affected.\n\nWhat it is: CVE-2026-82393 is a high-severity path traversal vulnerability in pnpm, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-82393 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pnpm (npm): affected all versions; fixed in 10.34.5\n- pnpm (npm): affected all versions; fixed in 10.34.5\n- pnpm (npm): affected from 11.0.0; fixed in 11.11.0\n- pnpm (npm): affected from 11.0.0; fixed in 11.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82393/ (Markdown: https://insights.sbomify.com/CVE-2026-82393/index.md)","id":"CVE-2026-82393","markdown":"https://insights.sbomify.com/CVE-2026-82393/index.md","name":"CVE-2026-82393","record":{"aliases":["GHSA-vq4v-j7r6-jq4m","MINI-3fq7-97cq-8r7q"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"pnpm package manager","requires_auth":"none","summary":"A malicious tarball dependency can overwrite arbitrary files during installation, potentially leading to code execution.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-73","name":"External Control of File Name or Path"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"pnpm is a package manager. Prior to 10.34.5 and 11.11.0, pnpm accepts a scoped path traversal in a tarball dependency's package.json manifest name because pnpm11/resolving/npm-resolver/src/pickPackage.ts rejects slash characters only for unscoped names. During pnpm install, the unvalidated name reaches raw path joins in pnpm11/installing/deps-resolver/src/resolvePeers.ts, pnpm11/installing/deps-resolver/src/index.ts, and pnpm11/deps/graph-builder/src/lockfileToDepGraph.ts, causing package extraction outside node_modules and allowing attacker-controlled files to overwrite arbitrary filesystem paths even when --ignore-scripts is used. The overwrite can replace shell startup files, Git hooks, or installed package code and lead to code execution. This issue is fixed in versions 10.34.5, and 11.11.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pnpm: A tarball dependency's manifest `name` escapes node_modules → arbitrary file write/overwrite on install","id":"CVE-2026-82393","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":4,"n_references":7,"next":{"headline":"Sulu: Fix authorization bypass when creating preview links","id":"CVE-2026-82394"},"packages":[{"ecosystem":"npm","fixed":["10.34.5"],"introduced":["0"],"last_affected":[],"package":"pnpm","purl":null,"source":"GHSA-vq4v-j7r6-jq4m"},{"ecosystem":"npm","fixed":["10.34.5"],"introduced":["0"],"last_affected":[],"package":"pnpm","purl":"pkg:npm/pnpm","source":"GHSA-vq4v-j7r6-jq4m"},{"ecosystem":"npm","fixed":["11.11.0"],"introduced":["11.0.0"],"last_affected":[],"package":"pnpm","purl":null,"source":"GHSA-vq4v-j7r6-jq4m"},{"ecosystem":"npm","fixed":["11.11.0"],"introduced":["11.0.0"],"last_affected":[],"package":"pnpm","purl":"pkg:npm/pnpm","source":"GHSA-vq4v-j7r6-jq4m"}],"prev":{"headline":"pnpm: Virtual store linker path traversal via unvalidated depPath name in lockfileToDepGraph","id":"CVE-2026-82392"},"products":["pnpm"],"published":"2026-08-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-02","vendors":["pnpm"]},"summary":"A malicious tarball dependency can overwrite arbitrary files during installation, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-82393/"}