# CVE-2026-82393: pnpm: A tarball dependency's manifest `name` escapes node_modules → arbitrary file write/overwrite on install

> A malicious tarball dependency can overwrite arbitrary files during installation, potentially leading to code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 2 Sep 2026
- **Also known as:** GHSA-vq4v-j7r6-jq4m, MINI-3fq7-97cq-8r7q

## What is CVE-2026-82393?

CVE-2026-82393 is a high-severity path traversal vulnerability in pnpm, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to 10.34.5 and 11.11.0, pnpm accepts a scoped path traversal in a tarball dependency's package.json manifest name because pnpm11/resolving/npm-resolver/src/pickPackage.ts rejects slash characters only for unscoped names. During pnpm install, the unvalidated name reaches raw path joins in pnpm11/installing/deps-resolver/src/resolvePeers.ts, pnpm11/installing/deps-resolver/src/index.ts, and pnpm11/deps/graph-builder/src/lockfileToDepGraph.ts, causing package extraction outside node_modules and allowing attacker-controlled files to overwrite arbitrary filesystem paths even when --ignore-scripts is used. The overwrite can replace shell startup files, Git hooks, or installed package code and lead to code execution. This issue is fixed in versions 10.34.5, and 11.11.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-82393?

4 open source packages ship an affected version, including pnpm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.34.5 |
| `pnpm` | npm | All versions | 10.34.5 |
| `pnpm` | npm | From 11.0.0 | 11.11.0 |
| `pnpm` | npm | From 11.0.0 | 11.11.0 |

## How do I fix CVE-2026-82393?

Upgrade pnpm to a fixed version for your release line: 10.34.5 or 11.11.0.

## Is CVE-2026-82393 being exploited?

There is no known exploitation of CVE-2026-82393 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82393 and fix it if it is affected.

What it is: CVE-2026-82393 is a high-severity path traversal vulnerability in pnpm, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-82393 in the wild and no public exploit code.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.34.5
- pnpm (npm): affected all versions; fixed in 10.34.5
- pnpm (npm): affected from 11.0.0; fixed in 11.11.0
- pnpm (npm): affected from 11.0.0; fixed in 11.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82393/ (Markdown: https://insights.sbomify.com/CVE-2026-82393/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82393
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82393
- OSV: https://osv.dev/vulnerability/CVE-2026-82393

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82393/
Summaries are generated and may contain mistakes; the official description above is the record.
