# CVE-2026-82397: Tornado: Urlencoded body parsing omits max_num_fields, so one request can stall the event loop

> An unauthenticated attacker can stall the Tornado event loop by sending a request with millions of form fields, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 2 Sep 2026
- **Also known as:** AZL-98544, BELL-CVE-2026-82397, CLEANSTART-2026-CX71098, CLEANSTART-2026-QT13587, CLEANSTART-2026-TA08611, CLEANSTART-2026-TZ94047, DEBIAN-CVE-2026-82397, ECHO-093b-7cf6-cf48, GHSA-mpf4-983q-p7j4, MINI-2g5r-vjx6-m3f4, MINI-2jc8-q35m-r3qx, MINI-2qxp-h68q-48fm, MINI-3g5j-49hx-3g9p, MINI-4hj2-cqq8-c54x, MINI-4rcf-hj2x-cfvp, MINI-59j8-c948-4683, MINI-7f2x-7j42-q74r, MINI-7p87-6cfw-cpj5, MINI-87j3-pj3r-7jcp, MINI-9927-8747-3x6f, MINI-9f2m-vjjj-fxg5, MINI-cc5q-8wf8-5qq7, MINI-cr7w-gjgj-vrjf, MINI-f5mh-86g8-8w6x, MINI-fxgp-v9gv-wgr8, MINI-g2fc-fj5v-qcw3, MINI-p2fq-mgm7-wc93, MINI-p78m-47vq-9hv2, MINI-p92m-g839-xrcg, MINI-qr69-rq4h-pp78, MINI-v3f9-w6qp-hxjq, MINI-xj59-7g92-9338, OESA-2026-3971, OESA-2026-3972, OESA-2026-3973, PYSEC-2026-3928, ROOT-APP-PYPI-CVE-2026-82397, SUSE-SU-2026:23523-1, SUSE-SU-2026:4073-1, SUSE-SU-2026:4076-1, UBUNTU-CVE-2026-82397

## What is CVE-2026-82397?

CVE-2026-82397 is a high-severity denial of service vulnerability in tornadoweb tornado, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tornado is a Python web framework and asynchronous networking library. Prior to 6.5.8, Tornado parses application/x-www-form-urlencoded request bodies with urllib.parse.parse_qs in tornado/escape.py without passing max_num_fields. RequestHandler._execute in tornado/web.py parses the body before handler dispatch through HTTPServerRequest._parse_body and parse_body_arguments in tornado/httputil.py, so an unauthenticated request body containing millions of separator-delimited fields can synchronously stall the single-threaded event loop and delay every connection. The body is bounded only by max_buffer_size, which defaults to 104857600 bytes. This issue is fixed in version 6.5.8.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-82397?

3 open source packages ship an affected version, including tornado.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 6.5.8 |
| `tornado` | PyPI | All versions | 6.5.8 |
| `tornado` | PyPI | All versions | 6.5.8 |
| `python-tornado` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado` | SUSE:Linux Enterprise Micro 5.3 | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado` | SUSE:Linux Enterprise Micro 5.4 | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado` | SUSE:Linux Enterprise Micro 5.5 | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado` | SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado` | SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 4.5.3-150000.3.28.1 |
| `python-tornado6` | SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 6.3.2-150400.9.24.1 |
| `python-tornado6` | SUSE:Linux Micro 6.1 | All versions | 6.4-slfo.1.1_7.1 |

## How do I fix CVE-2026-82397?

Upgrade tornado to 6.5.8 or later.

## Is CVE-2026-82397 being exploited?

There is no known exploitation of CVE-2026-82397 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82397 and fix it if it is affected.

What it is: CVE-2026-82397 is a high-severity denial of service vulnerability in tornadoweb tornado, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82397 in the wild and no public exploit code.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 6.5.8
- tornado (PyPI): affected all versions; fixed in 6.5.8
- tornado (PyPI): affected all versions; fixed in 6.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82397/ (Markdown: https://insights.sbomify.com/CVE-2026-82397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82397
- OSV: https://osv.dev/vulnerability/CVE-2026-82397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82397/
Summaries are generated and may contain mistakes; the official description above is the record.
