{"answers":{"affected":"5 open source packages ship an affected version, including github.com/pocketbase/pocketbase.","exploited":"There is no known exploitation of CVE-2026-82410 in the wild and no public exploit code.","fix":"Upgrade github.com/pocketbase/pocketbase to a fixed version for your release line: 0.22.48 or 0.39.7.","what":"CVE-2026-82410 is a high-severity denial of service vulnerability in pocketbase, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-82410 and fix it if it is affected.\n\nWhat it is: CVE-2026-82410 is a high-severity denial of service vulnerability in pocketbase, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-82410 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.48, 0.39.7\n- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.48\n- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.48\n- github.com/pocketbase/pocketbase (Go): affected from 0.23.0; fixed in 0.39.7\n- github.com/pocketbase/pocketbase (Go): affected from 0.23.0; fixed in 0.39.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82410/ (Markdown: https://insights.sbomify.com/CVE-2026-82410/index.md)","id":"CVE-2026-82410","markdown":"https://insights.sbomify.com/CVE-2026-82410/index.md","name":"CVE-2026-82410","record":{"aliases":["GHSA-84vh-m24q-wjjx","GO-2026-6489"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go backend server","requires_auth":"none","summary":"An attacker can crash the PocketBase server by triggering a panic in internal worker goroutines, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"Pocketbase is an open source web backend written in go. Prior to 0.22.48 and 0.39.7, PocketBase's panic-recovery middleware covers regular request handling but not internal child and worker goroutines. A panic in one of these internal goroutines can escape recovery and terminate the server process, causing a denial of service. The remediation introduces routine.SafeWrap to convert recovered panics into regular errors and applies it to the affected internal worker functions. This issue is fixed in versions 0.22.48 and 0.39.7.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pocketbase: Unhandled panic in worker goroutines","id":"CVE-2026-82410","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":5,"n_references":6,"next":{"headline":"Objects API: Cross-object-type authorization bypass on the object history-detail endpoint","id":"CVE-2026-82411"},"packages":[{"ecosystem":"Go","fixed":["0.22.48","0.39.7"],"introduced":["0","0.23.0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","source":"GO-2026-6489"},{"ecosystem":"Go","fixed":["0.22.48"],"introduced":["0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":null,"source":"GHSA-84vh-m24q-wjjx"},{"ecosystem":"Go","fixed":["0.22.48"],"introduced":["0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","source":"GHSA-84vh-m24q-wjjx"},{"ecosystem":"Go","fixed":["0.39.7"],"introduced":["0.23.0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":null,"source":"GHSA-84vh-m24q-wjjx"},{"ecosystem":"Go","fixed":["0.39.7"],"introduced":["0.23.0"],"last_affected":[],"package":"github.com/pocketbase/pocketbase","purl":"pkg:golang/github.com/pocketbase/pocketbase","source":"GHSA-84vh-m24q-wjjx"}],"prev":{"headline":"Klever-Go: Elasticsearch bulk / painless injection via on-chain account name -\u003e explorer/indexer data forgery","id":"CVE-2026-82409"},"products":["pocketbase"],"published":"2026-09-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-16","vendors":["pocketbase"]},"summary":"An attacker can crash the PocketBase server by triggering a panic in internal worker goroutines, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2026-82410/"}