# CVE-2026-82410: Pocketbase: Unhandled panic in worker goroutines

> An attacker can crash the PocketBase server by triggering a panic in internal worker goroutines, causing a denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-84vh-m24q-wjjx, GO-2026-6489

## What is CVE-2026-82410?

CVE-2026-82410 is a high-severity denial of service vulnerability in pocketbase, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pocketbase is an open source web backend written in go. Prior to 0.22.48 and 0.39.7, PocketBase's panic-recovery middleware covers regular request handling but not internal child and worker goroutines. A panic in one of these internal goroutines can escape recovery and terminate the server process, causing a denial of service. The remediation introduces routine.SafeWrap to convert recovered panics into regular errors and applies it to the affected internal worker functions. This issue is fixed in versions 0.22.48 and 0.39.7.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-82410?

5 open source packages ship an affected version, including github.com/pocketbase/pocketbase.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pocketbase/pocketbase` | Go | All versions | 0.22.48, 0.39.7 |
| `github.com/pocketbase/pocketbase` | Go | All versions | 0.22.48 |
| `github.com/pocketbase/pocketbase` | Go | All versions | 0.22.48 |
| `github.com/pocketbase/pocketbase` | Go | From 0.23.0 | 0.39.7 |
| `github.com/pocketbase/pocketbase` | Go | From 0.23.0 | 0.39.7 |

## How do I fix CVE-2026-82410?

Upgrade github.com/pocketbase/pocketbase to a fixed version for your release line: 0.22.48 or 0.39.7.

## Is CVE-2026-82410 being exploited?

There is no known exploitation of CVE-2026-82410 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82410 and fix it if it is affected.

What it is: CVE-2026-82410 is a high-severity denial of service vulnerability in pocketbase, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82410 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.48, 0.39.7
- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.48
- github.com/pocketbase/pocketbase (Go): affected all versions; fixed in 0.22.48
- github.com/pocketbase/pocketbase (Go): affected from 0.23.0; fixed in 0.39.7
- github.com/pocketbase/pocketbase (Go): affected from 0.23.0; fixed in 0.39.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82410/ (Markdown: https://insights.sbomify.com/CVE-2026-82410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82410
- OSV: https://osv.dev/vulnerability/CVE-2026-82410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82410/
Summaries are generated and may contain mistakes; the official description above is the record.
