# CVE-2026-82416: FrankenPHP: Cross-request PHP session ID leak in worker mode when the session extension is a shared module

> Attackers can hijack sessions or view other users' data in FrankenPHP worker mode if the session extension is loaded as a shared module.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-v3ph-cgqh-r8p5, GO-2026-6797

## What is CVE-2026-82416?

CVE-2026-82416 is a high-severity vulnerability in frankenphp, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FrankenPHP is a modern application server for PHP. Prior to 1.12.5, FrankenPHP worker mode can retain PHP session state between requests when the session extension is loaded as a shared module and is unavailable through HAVE_PHP_SESSION at compile time. In this build configuration, frankenphp_reset_session_state() is compiled out, PS(id) can survive a request boundary, and a subsequent session_start() can ignore the new request's cookie because an identifier is already present. Under concurrent requests, session_id() can therefore return another client's identifier or a stale identifier from a previous request on the same worker thread, causing cross-user session exposure, possible session hijacking, and intermittent logout behavior. Builds with the session extension statically linked, including the official static binaries and Docker images, are not affected. This issue is fixed in version 1.12.5.

Weakness: CWE-488 (Exposure of Data Element to Wrong Session), CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-82416?

3 open source packages ship an affected version, including github.com/dunglas/frankenphp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.12.5 |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.12.5 |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.12.5 |

## How do I fix CVE-2026-82416?

Upgrade github.com/dunglas/frankenphp to 1.12.5 or later.

## Is CVE-2026-82416 being exploited?

There is no known exploitation of CVE-2026-82416 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82416 and fix it if it is affected.

What it is: CVE-2026-82416 is a high-severity vulnerability in frankenphp, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82416 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.12.5
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.12.5
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.12.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82416/ (Markdown: https://insights.sbomify.com/CVE-2026-82416/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82416
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82416
- OSV: https://osv.dev/vulnerability/CVE-2026-82416

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82416/
Summaries are generated and may contain mistakes; the official description above is the record.
