# CVE-2026-82561: Apache NiFi: Missing Authorization for Components Referenced in Flow Update Methods

> Authenticated users with write access can modify protected components in descendant groups or bind unauthorized services due to missing authorization checks.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L/S:N/AU:Y/R:U/V:C/RE:L/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** BIT-nifi-2026-82561, GHSA-hfp7-cf28-6f6q, MINI-76mw-rg95-q793

## What is CVE-2026-82561?

CVE-2026-82561 is a medium-severity missing authorization vulnerability in Apache Nifi, published on 16 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Apache NiFi 1.5.0 through 2.11.0 provide REST API methods that replace the entire contents of a Process Group using a client-supplied flow definition, covering Process Group flow replacement together with versioned flow update and rebase operations. Framework authorization for these methods was limited to read and write privileges on the Process Group itself, unlike the corresponding asynchronous update request methods, which also authorize the components encapsulated in the Process Group along with referenced Controller Services, Parameter Contexts, and Parameter Providers. As a result of the missing authorization, an authenticated user with write access to a Process Group could supply a flow definition that modifies or removes components in descendant Process Groups protected by more restrictive access policies, and could bind components to Controller Services and Parameter Contexts without authorization for those referenced components. Existing verification checks limited the impact to stopped components, and the issue applies only to deployments that use component-level authorization policies, because the framework enforces write permissions as the security boundary. Upgrading to Apache NiFi 2.12.0 is the recommended mitigation, which applies consistent reference resolution and component authorization across Process Group replacement and versioned flow update methods

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-82561?

1 open source package ship an affected version, including nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nifi` | Bitnami | From 1.5.0 | 2.12.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-82561?

Upgrade nifi to 2.12.0 or later.

## Is CVE-2026-82561 being exploited?

There is no known exploitation of CVE-2026-82561 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82561 and fix it if it is affected.

What it is: CVE-2026-82561 is a medium-severity missing authorization vulnerability in Apache Nifi, published on 16 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82561 in the wild and no public exploit code.

Affected packages and fixed versions:
- nifi (Bitnami): affected from 1.5.0; fixed in 2.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82561/ (Markdown: https://insights.sbomify.com/CVE-2026-82561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82561
- OSV: https://osv.dev/vulnerability/CVE-2026-82561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82561/
Summaries are generated and may contain mistakes; the official description above is the record.
