# CVE-2026-82562: qs array-limit bypass via bracket-key comma parsing

> Attackers can cause denial of service by bypassing array limits in the qs library when specific parsing options are enabled, leading to excessive memory allocation.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** CLEANSTART-2026-JI81850, CLEANSTART-2026-JM60030, CLEANSTART-2026-MU53391, CLEANSTART-2026-VG34156, CLSA-2026-1791453817, CLSA-2026-1791626353, CLSA-2026-1793015982, CLSA-2026-1793098692, DEBIAN-CVE-2026-82562, ECHO-6127-5c52-905f, GHSA-x5fp-wj9c-mxmx, MINI-2gpc-4p3j-7c5j, MINI-3cfw-98f5-3p8g, MINI-426h-g9pr-cm4p, MINI-575r-hwx7-qcr8, MINI-59p8-g25p-39f5, MINI-5mw9-fhcq-44jp, MINI-94wp-85xf-5mrr, MINI-c3qf-9x2c-cp73, MINI-gcxg-qrg8-v65w, MINI-ghmx-x25w-j3xp, MINI-gpq5-869m-hm6r, MINI-hhfr-pfjv-r73j, MINI-hmqq-3g58-8p27, MINI-j37x-3ppr-fvw3, MINI-j8g9-hq2c-932q, MINI-m3f7-mggv-jxrm, MINI-m947-8v2j-695h, MINI-mj45-cm6x-3h6c, MINI-p846-rjmp-2cf3, MINI-pj88-42xg-qh2g, MINI-q2cm-qmv6-xv9f, MINI-v7qr-hqm9-35m8, MINI-wm59-c8vv-gfq4, MINI-wm7h-9m2c-hgf7, UBUNTU-CVE-2026-82562

## What is CVE-2026-82562?

CVE-2026-82562 is a medium-severity denial of service vulnerability in ljharb qs, published on 29 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary

When `qs.parse` is called with `comma: true` and `throwOnLimitExceeded: true`, a comma-separated value under a bracket-push key (`a[]=1,2,3,4`) is split into an array without being compared against `arrayLimit`, while the same value under a flat key (`a=1,2,3,4`), an indexed key (`a[0]=`), a nested key (`a[b]=`), or a dotted key (`a.b=` with `allowDots`) throws the documented `RangeError`. A single parameter such as `a[]=1,2,2,...` therefore produces an inner array of arbitrary length even though the caller opted into the hard limit. This is the `[]=` key form that the fix for CVE-2026-2391 (qs 6.14.2) did not cover.

### Details

In `lib/parse.js`, a comma-separated value under a `[]=` key is split and then wrapped as a single nested element (`val = [val]`, so that each `a[]=x,y` group counts as one element of the outer array). The `arrayLimit` check that 6.14.2 added for comma values runs after that wrap, so for `[]=` parts it only ever saw the wrapper of length 1. 6.15.3 added a pre-split comma count so that an oversized value throws before it is allocated, but gated it on an `isFlatArrayValue` flag that `parseValues` set to `false` for any part containing `[]=`, and did not pass it for object-valued input, so the gap remained.

#### PoC

```js

var qs = require('qs');

var options = { comma: true, arrayLimit: 3, throwOnLimitExceeded: true };

qs.parse('a=1,2,3,4', options);   // RangeError: Array limit exceeded. Only 3 elements allowed in an array.

qs.parse('a[]=1,2,3,4', options); // { a: [ [ '1', '2', '3', '4' ] ] }  (no throw)

qs.parse('a[]=' + '1,'.repeat(1000000) + '1', { comma: true, arrayLimit: 20, throwOnLimitExceeded: true });

// no throw; a 1,000,001-element inner array is allocated

```

#### Fix

`lib/parse.js`, applied in 8859c37 on `main` and released as v6.16.0: the `isFlatArrayValue` gate is removed, so every comma-split value is counted against `arrayLimit` before splitting regardless of key form. An in-limit group under `a[]=` still counts as one element of the outer array, and the default (`throwOnLimitExceeded: false`) path is unchanged.

### Affected versions

`>=6.14.2 <6.16.0`, fixed in v6.16.0.

v6.14.2 introduced `arrayLimit` enforcement for comma values (the fix for CVE-2026-2391) but only for values not under a `[]=` key, and every release from v6.14.2 through v6.15.3 has the same gap. v6.14.0 and v6.14.1, where `throwOnLimitExceeded` exists but does not apply to any comma form, are covered by CVE-2026-2391 rather than this record. Earlier lines (6.7.x through 6.13.x) have `comma` but no `throwOnLimitExceeded`, so there is no hard cap on any comma path to bypass; releases before 6.7.0 have no `comma` option.

### Impact

An unauthenticated attacker who can reach an application that parses untrusted query strings or urlencoded bodies with both `comma: true` and `throwOnLimitExceeded: true` (both non-default) can bypass the configured limit with a single `a[]=` parameter and force the parser to allocate an array proportional to the request size. The cost is strictly linear in the attacker-supplied bytes (about 0.1 microseconds and 6 to 7 retained bytes per input byte; the same out-of-memory threshold as the documented default `throwOnLimitExceeded: false` path), so a transport-layer request or body size limit bounds it completely (and node's default maximum HTTP header size of 16 KB already bounds the request line, so multi-megabyte payloads need a body parser). The impact is that an opt-in hard limit fails open on one key spelling, not unbounded allocation from a small input.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-82562?

2 open source packages ship an affected version, including qs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qs` | npm | From 6.14.2 | 6.16.0 |
| `qs` | npm | From 6.14.2 | 6.16.0 |

## How do I fix CVE-2026-82562?

Upgrade qs to 6.16.0 or later.

## Is CVE-2026-82562 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82562 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82562 and fix it if it is affected.

What it is: CVE-2026-82562 is a medium-severity denial of service vulnerability in ljharb qs, published on 29 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82562 exists.

Affected packages and fixed versions:
- qs (npm): affected from 6.14.2; fixed in 6.16.0
- qs (npm): affected from 6.14.2; fixed in 6.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82562/ (Markdown: https://insights.sbomify.com/CVE-2026-82562/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82562
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82562
- OSV: https://osv.dev/vulnerability/CVE-2026-82562

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82562/
Summaries are generated and may contain mistakes; the official description above is the record.
