# CVE-2026-82564: Identity tool filter in AshAi accepts operator maps, allowing update or destroy of unidentified records

> Attackers can bypass identity checks to modify or delete arbitrary records by manipulating filter arguments in AshAi tools.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 1 Sep 2026
- **Also known as:** EEF-CVE-2026-82564, GHSA-jg86-xh36-h5xc

## What is CVE-2026-82564?

CVE-2026-82564 is a high-severity missing authorization vulnerability in ash-project ash_ai, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Authorization Bypass Through User-Controlled Key vulnerability in ash-project ash_ai allows a caller of an identity-configured tool to update or destroy records it never identified, including every row in the table.

In AshAi.Tool.Execution, identity_filter/3 built the update/destroy filter directly from the raw tool arguments as [{key, Map.get(arguments, to_string(key))}] and passed it to Ash.Query.do_filter/2. A map value is parsed as a predicate expression rather than a literal, so a caller can send {"public_ref": {"not_eq": "<own-ref>"}} and, combined with Ash.Query.limit(1) and Ash.bulk_update!/Ash.bulk_destroy!, retarget the write at a record it never identified; an omitted key yields an IS NULL filter that matches an arbitrary row. The fix casts each identity value to the field type, rejecting non-scalar inputs.

This issue affects ash_ai: from 0.6.0 before 1.0.0.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-82564?

1 open source package ship an affected version, including ash_ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_ai` | Hex | From 0.6.0 | 1.0.0 |

## How do I fix CVE-2026-82564?

Upgrade ash_ai to 1.0.0 or later.

## Is CVE-2026-82564 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82564 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82564 and fix it if it is affected.

What it is: CVE-2026-82564 is a high-severity missing authorization vulnerability in ash-project ash_ai, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82564 exists.

Affected packages and fixed versions:
- ash_ai (Hex): affected from 0.6.0; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82564/ (Markdown: https://insights.sbomify.com/CVE-2026-82564/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82564
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82564
- OSV: https://osv.dev/vulnerability/CVE-2026-82564

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82564/
Summaries are generated and may contain mistakes; the official description above is the record.
