# CVE-2026-82580: AshAi echoes raw tool exception messages into the conversation, disclosing internal details

> Attackers can trigger tool exceptions to leak sensitive internal error details, such as database constraints or query fragments, to chat users.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** EEF-CVE-2026-82580, GHSA-5747-6mpw-6m9c

## What is CVE-2026-82580?

CVE-2026-82580 is a medium-severity vulnerability in ash-project ash_ai, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Generation of Error Message Containing Sensitive Information vulnerability in ash-project ash_ai discloses internal error text to chat users.

In AshAi.ToolLoop and AshAi.Tools, an exception raised while executing a tool was serialized verbatim with Exception.message/1 into the tool-result content. That content is appended to the conversation, emitted as a {:tool_result, ...} stream event, and sent back to the model, which typically relays it to the user. No filtering happened first, so anything raised inside a tool callback or lifecycle hook (database constraint messages, adapter errors, query fragments, policy or validation internals) was echoed as-is. A chat user who can steer tool arguments into a raising code path receives the raw internal text. The fix routes raised tool errors through the same safe formatter used for other tool errors.

This issue affects ash_ai: from 0.6.0 before 1.0.0.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-82580?

1 open source package ship an affected version, including ash_ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_ai` | Hex | From 0.6.0 | 1.0.0 |

## How do I fix CVE-2026-82580?

Upgrade ash_ai to 1.0.0 or later.

## Is CVE-2026-82580 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82580 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82580 and fix it if it is affected.

What it is: CVE-2026-82580 is a medium-severity vulnerability in ash-project ash_ai, published on 31 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-82580 exists.

Affected packages and fixed versions:
- ash_ai (Hex): affected from 0.6.0; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82580/ (Markdown: https://insights.sbomify.com/CVE-2026-82580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82580
- OSV: https://osv.dev/vulnerability/CVE-2026-82580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82580/
Summaries are generated and may contain mistakes; the official description above is the record.
