{"answers":{"affected":"1 open source package ship an affected version, including igniter.","exploited":"There is no known exploitation of CVE-2026-82584 in the wild and no public exploit code.","fix":"Upgrade igniter to 0.8.4 or later.","what":"CVE-2026-82584 is a low-severity vulnerability in ash-project igniter, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-82584 and fix it if it is affected.\n\nWhat it is: CVE-2026-82584 is a low-severity vulnerability in ash-project igniter, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-82584 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- igniter (Hex): affected from 0.8.1; fixed in 0.8.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-82584/ (Markdown: https://insights.sbomify.com/CVE-2026-82584/index.md)","id":"CVE-2026-82584","markdown":"https://insights.sbomify.com/CVE-2026-82584/index.md","name":"CVE-2026-82584","record":{"aliases":["EEF-CVE-2026-82584","GHSA-cj7w-j579-gc42"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Elixir dependency manager","requires_auth":"none","summary":"Attackers can forge terminal confirmation prompts via escape sequences in package metadata, deceiving developers into installing malicious dependencies.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-150","name":"Improper Neutralization of Escape, Meta, or Control Sequences"}],"description":"Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in ash-project igniter allows a malicious package publisher to forge the mix igniter.install confirmation prompt.\n\nmix igniter.install prints a confirmation panel (an anti-typosquatting safeguard) listing a package's hex metadata before adding it. The panel builder in Igniter.Project.Deps wrote publisher-controlled fields (meta.description, owner usernames, requirement names, version) to the terminal with only newlines stripped. A malicious or typosquatted package can embed ANSI terminal escape sequences (cursor movement, line erase, carriage returns) in its metadata to overwrite the panel, forging trusted author names and download counts while concealing the real ones, so a developer relying on the panel to vet the package is deceived into approving a malicious dependency.\n\nThis issue affects igniter: from 0.8.1 before 0.8.4.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Terminal escape sequence injection in the mix igniter.install confirmation prompt via package metadata","id":"CVE-2026-82584","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"other","year":"2026"},"n_packages":1,"n_references":4,"next":{"headline":"Botslab G980H Dashcams Cleartext Transmission of Sensitive Information","id":"CVE-2026-82585"},"packages":[{"ecosystem":"Hex","fixed":["0.8.4"],"introduced":["0.8.1"],"last_affected":[],"package":"igniter","purl":"pkg:hex/igniter","source":"EEF-CVE-2026-82584"}],"prev":{"headline":"NextGen Healthcare Mirth Connect SQL Injection","id":"CVE-2026-82583"},"products":["igniter"],"published":"2026-09-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-08","vendors":["ash-project"]},"summary":"Attackers can forge terminal confirmation prompts via escape sequences in package metadata, deceiving developers into installing malicious dependencies.","url":"https://insights.sbomify.com/CVE-2026-82584/"}