# CVE-2026-82586: AshLua read operation aggregate bypasses the exposed-field allow-list, exposing private attributes

> A user-supplied Lua script can bypass exposed-field restrictions to read private attributes, including sensitive data like hashed passwords.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** EEF-CVE-2026-82586, GHSA-37jv-wc37-fhcw

## What is CVE-2026-82586?

CVE-2026-82586 is a high-severity vulnerability in ash-project ash_lua, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Protection of Alternate Path vulnerability in ash-project ash_lua allows a user-supplied Lua script to read attributes that are not on the exposed-field allow-list.

AshLua exposes Ash resources to Lua scripts, gated by a manifest declaring which fields are exposed. The read action's operation aggregate path in AshLua.Runtime took the field name straight from the Lua call and resolved it with only String.to_existing_atom and Ash.Query.Aggregate.new!, neither of which consults the exposed-field allow-list the normal fields path enforces. A script can therefore read the value of any attribute of any record the actor may read, including private sensitive?: true columns, via resource.read({ operation = {"list", "hashed_password"} }); min and max give a value oracle. Anyone able to submit or influence a Lua script can reach this.

This issue affects ash_lua: from 0.1.0 before 0.2.1.

Weakness: CWE-424 (Improper Protection of Alternate Path)

## Which versions are affected by CVE-2026-82586?

1 open source package ship an affected version, including ash_lua.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_lua` | Hex | From 0.1.0 | 0.2.1 |

## How do I fix CVE-2026-82586?

Upgrade ash_lua to 0.2.1 or later.

## Is CVE-2026-82586 being exploited?

There is no known exploitation of CVE-2026-82586 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-82586 and fix it if it is affected.

What it is: CVE-2026-82586 is a high-severity vulnerability in ash-project ash_lua, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-82586 in the wild and no public exploit code.

Affected packages and fixed versions:
- ash_lua (Hex): affected from 0.1.0; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-82586/ (Markdown: https://insights.sbomify.com/CVE-2026-82586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-82586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-82586
- OSV: https://osv.dev/vulnerability/CVE-2026-82586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-82586/
Summaries are generated and may contain mistakes; the official description above is the record.
